Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Pinging Gateway: Host unreachable
Results 1 to 7 of 7

Thread: Pinging Gateway: Host unreachable

  1. #1

    Pinging Gateway: Host unreachable

    Hi, Im hoping to have an answer to this issue. I disabled NetworkManager and used Network service. I cannot ping anything even the gateway.

    IP: 172.20.1.224
    Mask: 255.255.0.0
    GW: 172.20.1.59

    I can ping my own IP, loopback address but not the GW. I also disabled firewall. Route -n shows my GW too, which is 172.20.1.59. I used network service and edited /etc/sysconfig/network-scripts/ifcfg-eth0.

    DEVICE=eth0
    TYPE=Ethernet
    BOOTPROTO=none
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=yes
    IPV6INIT=no
    NAME="System eth0"
    UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
    ONBOOT=yes
    USERCTL=no
    IPADDR=172.20.1.224
    PREFIX=16
    GATEWAY=172.20.1.59
    DNS1=4.2.2.2
    HWADDR=00:21:70:C0:7C:ED


    If i use DHCP, it would say check the ethernet cable something. Am i missing something here? I can say the settings were correct since it worked 2 days ago. Im not sure if someone played with it then. PLease help.

  2. #2
    ok do 1 thng

    ---- install dhcp by yum

    -----check if it installed by rpm -qa | grep dhcp

    -----chnge disk ie cd /etc/

    ------open dhcp.conf by cat


    -------make the chnges in 1) subnet (put ur ip in this )

    2) option router (put ur ip series eg if ip is 198.168.20.1 thn the series is 20 . put this series)

    3) option ns name ( disable it by putting # at begining of it)

    4) domain name ( put ur domain name like abc.com)


    5) lease time it is in seconds and ur ip will exist as long as this time does not end


    6) giv the range of ip addresses that are in network


    i think this must solve ur issue.......report me what happened

  3. #3
    Sorry for the late reply. I was away this weekend. If this helps, can I confirm If this is a driver issue? If so, can we just reload the driver?

    Mar 28 17:05:27 rom-laptop kernel: [ 707.672031] eth0: auto-negotiating...
    Mar 28 17:05:37 rom-laptop kernel: [ 717.696030] eth0: auto-negotiating...
    Mar 28 17:05:47 rom-laptop kernel: [ 727.720031] eth0: auto-negotiating...
    Mar 28 17:05:57 rom-laptop kernel: [ 737.744031] eth0: auto-negotiating...
    Mar 28 17:06:07 rom-laptop kernel: [ 747.768030] eth0: auto-negotiating...

  4. #4
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    it looks like eth0 can't figure out wether to run 100Mb full duplex or half dulpex, you can check this with mii-tool ie:
    # mii-tool eth0

    it will report what the interface is configured to, with this you can also foce a mode onto the interface ie:
    # mii-tool -F 100baseTx-FD eth0

    for 100Mb full duplex, then it won't try to autonegotiate.
    But are you sure it's not failing in the autonegotiate due to a faulty plug on the cable ?
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  5. #5
    # mii-tool -F 100baseTx-FD eth0

    I ran that and ran mii-tool to check the settings, it still says eth0: 10Mbit, half duplex, no link. Does this mean that my card is bad? And yes the cable is good since it worked on my Windows laptop.

  6. #6
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    no link
    indicates theres no connection, ie, the diode indicator on the port wont even flash.
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  7. #7
    try

    /etc/sysconfig/network-scripts/ifcfg-eth0 up

    and service network restart

    If you get any error put it here

Similar Threads

  1. "Network is unreachable" when pinging gateway through DHCP
    By Setya in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 07-25-2007, 02:48 AM
  2. Replies: 5
    Last Post: 04-29-2007, 02:35 PM
  3. Virtual host/local host PAM File problem!
    By honey bee in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 03-01-2006, 01:38 PM
  4. Pinging
    By headshock in forum Windows - General Topics
    Replies: 2
    Last Post: 02-24-2005, 10:17 PM
  5. Configuring IP Masquerading [linux host to Wins gateway]
    By juno in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 06-01-2002, 01:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •