Results 1 to 2 of 2

Thread: Problems bridging wlan0 and ppp0

  1. #1

    Problems bridging wlan0 and ppp0

    I'm trying to create an AP that is bridged to a GSM USB card on ppp0 ( ) so I can share that connection with other computers. (I live in an area where there is no other way to connect to the internet).

    I have configured my wlan0 as an AP at The dhcp3-server is passing out IPs to clients correctly, however I am unable to bridge the connection. And hostapd generates a "deauthenticated due to local deauth request" and drops the connection.

    In the dhcp.conf I tried to point to my ppp0 port with this "option routers" as suggested elsewhere.

    subnet netmask {
    option routers;
    option ip-forwarding off;
    option subnet-mask;
    option broadcast-address;
    I've also tried using the wireless-tools to make a bridge with the ppp0 and wlan0 but apparently ppp0 won't work (perhaps because it is ppp):
    sudo brctl addif br0 ppp0
    cant add ppp0 to bridge br0: Invalid argument
    Also I tried adding the bridge command inside the hostpad.conf file
    wpa_pairwise=TKIP CCMP
    Does anyone have some other ideas that might work for me? I know that once the bridge is working I'll probably need to modify the IP tables to allow for NAT to handle the traffic but I'm not quite there yet I don't think.

  2. #2


    The solution was two part. There was a problem with the hostapd.conf for WPA which caused the deauthentication problem. I just opened the network up and that problem went away so I'll have to look into that further.

    Fixing the bridge was done through IP tables. I found that tool firestarter allowed me to bridge the PPP0 and WLAN0 connections pretty easily and I can also monitor the traffic with it.

Similar Threads

  1. iwlist wlan0 scan
    By countach44 in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 05-11-2005, 04:41 PM
  2. KDE 3.0 problems already
    By boblucci in forum Linux - Software, Applications & Programming
    Replies: 21
    Last Post: 07-30-2002, 09:31 PM
  3. ifup ppp0
    By Bogler in forum Linux - General Topics
    Replies: 11
    Last Post: 07-10-2002, 09:57 PM
  4. Second HD - Problems with
    By papanohair in forum Linux - General Topics
    Replies: 1
    Last Post: 04-12-2002, 02:49 AM
  5. ppp0 and network
    By elovkoff in forum Linux - General Topics
    Replies: 8
    Last Post: 03-05-2002, 03:44 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts