Results 1 to 4 of 4

Thread: Files get corrupted when transfered over LAN

  1. #1

    Files get corrupted when transfered over LAN

    Hi,

    I needed to transfer files from my laptop (running Mint7 Xfce) to my desktop (running Mint9 Gnome) - I connected the two box via ethernet and used User share/pyNeighborhood. So far so good. I was able to transfer my files. But then I realized that some files were corrupted. I tried to work this out on my own but unsuccessfully. I noticed that when I start a session with pyNeighborhood, to transfer files to my desktop, the first file will be OK, but the following will be corrupted (more and more with each new files being transfered). If I unmount the share and re-mount it and then transfer a file, usually it is not corrupted. If I try to transfer another one, it will be corrupted.

    Anyone has an idea?

    Many thanks

  2. #2
    Are both using the same version of pyNeighborhood? Have you tried transferring via Samba just to eliminate the connection or software causing it?
    arrogance breeds ignorance

    Screaming Electron, Full of BSD Goodness

  3. #3
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,925
    I agree with the Samba suggestion. If, for some reason, you can't use that, then consider archiving the files you need and transferring the archive (zip, 7zip, tar, tar.bz2...etc). That might eliminate the corruption issue if you are only transferring the one file (the archive file with your other files within).
    The one serious conviction that a man should have is that nothing is to be taken too seriously.
    Where facts are few, experts are many.

  4. #4
    Hi,

    Thanks for the suggestion. I have been able to go around the problem by using Giver. It seems to work perfectly.

    Concerning my initial problem, I was not using PyNeighborhood on both box. I used PyNeighborhood on my laptop to connect to my desktop where I had a shared folder (I did that with the "User share" or "Nautilus share" function) I could access on the LAN with PyNeighborhood. It seemed to me that is was a Samba thing because it is about what I was doing when my Desktop was still running WinXP (I used to connect my Linux laptop to my WinXP desktop and transfer files without a problem).

    I'd like to understand what's wrong (just for the sake of learning), but in the mean time I'll use Giver.

    Many thanks again,

Similar Threads

  1. Decrypted file corrupted (EFS).
    By barion00 in forum Windows - General Topics
    Replies: 0
    Last Post: 05-08-2006, 04:12 PM
  2. Kernel panic - CPU text corrupted
    By hawkcl in forum Linux - Hardware, Networking & Security
    Replies: 8
    Last Post: 09-21-2005, 04:53 PM
  3. Corrupted Trash Icon
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 04-26-2004, 10:09 PM
  4. Grub got corrupted
    By doggiebone in forum Redhat / Fedora
    Replies: 7
    Last Post: 10-21-2002, 01:16 AM
  5. EvilestKnight has been corrupted
    By in forum General Chat
    Replies: 28
    Last Post: 11-30-2001, 09:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •