View Poll Results: Samba Swat Error !!

Voters
0. You may not vote on this poll
  • Unable to open page

    0 0%
  • http service is running !!

    0 0%
Results 1 to 3 of 3

Thread: Samba Swat Error !!

  1. #1

    Samba Swat Error !!

    Hi
    I m configuraing the samba-swat. i had done all requie setting , but enable to open page in browser ..

    Below are setting i done : -

    [root@server1 software]# rpm -qa samba-swat
    samba-swat-3.0.33-3.15.el5_4.1

    [root@server1 software]# vi /etc/xinetd.d/swat
    service swat
    {
    port = 901
    socket_type = stream
    wait = no
    protocol = tcp
    only_from = 127.0.0.1
    user = root
    server = /usr/sbin/swat
    log_on_failure += USERID
    disable = yes
    }


    [root@server1 software]# service smb restart
    [root@server1 software]# service xinetd restart


    but i m not been able to open page in browser

    in browser i use " http://172.0.0.1:901/


    Please help me out in this !!!

    Thanks

    Bhagyesh

  2. #2
    Administrator Associate gr8rcake's Avatar
    Join Date
    May 2004
    Posts
    44
    You seem to be using the incorrect address in your browser. It should be 127.0.0.1.
    The line "only_from = 127.0.0.1" only allows access from localhost, you will have to add more IP addresses if you want to add access from other computers.

  3. #3
    Associate
    Join Date
    Sep 2007
    Location
    idaho
    Posts
    16
    Quote Originally Posted by gr8rcake View Post
    You seem to be using the incorrect address in your browser. It should be 127.0.0.1.
    The line "only_from = 127.0.0.1" only allows access from localhost, you will have to add more IP addresses if you want to add access from other computers.
    You can also substitute localhost for 127.0.0.1. But before any of that works, you have to go backa to /etc/xinetd.d/swat and change "disable = yes" to "disable = no". If you don't do that, it doesn't matter what you put as http. So after changing 'swat' file, you can put either http://localhost:901 or http://127.0.0.1 .
    good luck

    EDIT: After re-reading the quote, I think it need clarified - you can only bring up "swat" w/ the addresses I gave above - whatever line was quoted above doesn't have anything to do w/ general internet access.
    Last edited by lynnevan; 05-04-2010 at 04:57 PM. Reason: clarification

Similar Threads

  1. Samba SWAT problems
    By cheezetrix in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 05-01-2004, 03:20 PM
  2. Samba Error
    By infinite_root in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 03-22-2004, 03:56 AM
  3. Samba error
    By datamike in forum Linux - General Topics
    Replies: 2
    Last Post: 01-14-2003, 04:05 PM
  4. samba swat and 7.3 redhat
    By doggiebone in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 06-06-2002, 09:43 PM
  5. Samba Swat and Redhat 7.2
    By thayne in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 03-04-2002, 09:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •