Results 1 to 6 of 6

Thread: Squid Configuration

Hybrid View

  1. #1
    Newbie
    Join Date
    Feb 2010
    Posts
    3

    Post Squid Configuration

    Hi All

    I want to restrict facebook from 9.00 to 12.30 and 1.30 to 3.00. and also to the IP Address in the range of 192.168.130.3 to 192.168.130.22. so I am using squid as my proxy server.

    Please send me the exact command for do that ?

    I have restrict the site successfully, but to allocate time is little bit ?

    acl scope_pclab src 192.168.130.3-192.168.130.22
    acl social_networking_dst_block dstdomain "/etc/squid/deny_lst/social_networking_dst"
    http_access deny social_networking_dst_block scope_pclab

    Note : the social_networking_dst : contains .facebook.com

    Thanks...

  2. #2
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Have you tried the Squid configuration page on the site?

  3. #3
    Newbie
    Join Date
    Feb 2010
    Posts
    3
    Yes I have ?

    I have to enable my network computers to use this proxy ! how can I enable it too ?
    My network is 192.168.130.0 /24 range 192.168.130.1-192.168.130.254

    Thanks You

  4. #4
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    You'll have to configure your browser settings to use the proxy server. You can also get around this by setting up a transparent proxy. Is your squid server your network router? That makes set up of the transparent proxy much easier.

    Some routers like the Linksys WRT54GL allow you to run the open wrt firmware on them and I think that allows binding to a squid server.

  5. #5
    Newbie
    Join Date
    Feb 2010
    Posts
    3
    I have configured to use the proxy for the client internet connection, but It doesn't work.?

    My squid.conf is like this,

    acl my_net src 192.168.130.0/255.255.255.0

    acl worktimeM time SMTWHFA 01:00-09:00
    acl worktimeL time SMTWHFA 12:30-13:30
    acl worktimeE time SMTWHFA 15:00-23:59

    acl social_networking_block url_regex "/etc/squid/deny_lst/social_networking"
    http_access deny social_networking_block

  6. #6
    hey gsnm, do 1 thng....istead of typing the sites in squid.conf.. go to /usr/local/etc i.e cd /usr/local/etc
    then open with nano or vi restrictedsites.squid ....put the name of the sites in this .... thn open squid.conf n write
    acl badsites dstdomain "usr/local/etc/restrictedsites.squid"
    http_access deny badsites


    it will work ...report me wat happened

Similar Threads

  1. Replies: 2
    Last Post: 05-26-2014, 09:12 PM
  2. DNS Configuration
    By mrjrt in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 02-03-2010, 10:39 PM
  3. Squid configuration question. Client => HTTPS => proxy => HTTP => webserver
    By newhere in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 09-06-2008, 04:31 AM
  4. YUM configuration
    By pawnbeeta in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 01-20-2008, 06:20 PM
  5. Squid configuration document
    By suresh_infoguy in forum Linux - Software, Applications & Programming
    Replies: 13
    Last Post: 03-12-2007, 05:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •