Results 1 to 2 of 2

Thread: Unable to setup a NIS server setup on CentOS system

  1. #1

    Unable to setup a NIS server setup on CentOS system

    Hi,
    We are trying to set up a NIS server on a CentOS system. We need to have a NIS server which can provide NIS authentication to a couple of clients. We are practically new to all this stuff.
    Just googled to find some ideas about installing ypserv and ypbind and portmapper. We did all that and also started them successfully. But now the clients are not able to join to the NIS domain . The error log states "YP_DOMAIN NOT BOUND".
    I guess we have not entered the /etc/yp.conf, /etc/hosts files properly. Please let us know the detailed steps to setup a NIS server . Also, please let us know what entries should go into the different /etc/<file_names>? What is meant by HOSTNAME in the /etc/hosts file?
    Is there any other files which need to be changed? Are we missing any steps?

  2. #2
    Also to add-on, while executing the ypinit command we faced the following error:
    root@localhost yp]# ./ypinit -m
    At this point, we have to construct a list of the hosts which will run NIS
    servers. localhost.localdomain is in the list of NIS server hosts. Please cont inue to add
    the names for the other hosts, one per line. When you are done with the
    list, type a <control D>.
    next host to add: localhost.localdomain
    next host to add:
    The current list of NIS servers looks like this:
    localhost.localdomain
    Is this correct? [y/n: y] y
    We need a few minutes to build the databases...
    Building /var/yp/domain/ypservers...
    Running /var/yp/Makefile...
    gmake[1]: Entering directory `/var/yp/domain'
    gmake[1]: *** No rule to make target `all'. Stop.
    gmake[1]: Leaving directory `/var/yp/domain'
    make: *** [target] Error 2
    Error running Makefile.
    Please try it by hand.

Similar Threads

  1. mail server setup
    By monkey0101010 in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-13-2006, 08:20 PM
  2. New Router setup unable to web browse..
    By Nu-B in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 03-05-2006, 04:49 PM
  3. How to setup and configure the SMTP (mailserver system) ?
    By goonfui_wong in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 06-25-2005, 10:07 PM
  4. chat server setup
    By manjunath.bn in forum Linux - General Topics
    Replies: 1
    Last Post: 11-29-2004, 09:07 PM
  5. Multi system setup
    By Kernel_Killer in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 03-08-2003, 09:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •