Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
LDAP migrate_all_offline.sh
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: LDAP migrate_all_offline.sh

  1. #1

    LDAP migrate_all_offline.sh

    Hi. I am trying to install LDAP on my system using the tutorial here. I'm just at the "Configuring The LDAP Server: Create Your LDAP Database" part of the tutorial. I get the errors below. Can anyone help? Thanks.

    [root@localhost example.com]# /usr/share/openldap/migration/migrate_all_offline.sh
    Creating naming context entries...
    Can't open perl script "migrate_base.pl": No such file or directory
    Migrating aliases...
    Can't open perl script "migrate_aliases.pl": No such file or directory
    Migrating groups...
    Can't open perl script "migrate_group.pl": No such file or directory
    Migrating hosts...
    Can't open perl script "migrate_hosts.pl": No such file or directory
    Migrating networks...
    Can't open perl script "migrate_networks.pl": No such file or directory
    Migrating users...
    Can't open perl script "migrate_passwd.pl": No such file or directory

  2. #2
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Try running the script from the /usr/share/openldap/migration/ directory. The script may be referencing scripts in its home directory assuming that it is being run there already.

    My sites:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  3. #3
    Quote Originally Posted by peter View Post
    Try running the script from the /usr/share/openldap/migration/ directory. The script may be referencing scripts in its home directory assuming that it is being run there already.
    that didn't work

    [root@localhost migration]# pwd
    /usr/share/openldap/migration
    [root@localhost migration]# migrate_all_offline.sh
    bash: migrate_all_offline.sh: command not found
    [root@localhost migration]#

  4. #4
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Try ./migrate_all_offline.sh instead.

    My sites:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  5. #5
    i think i need to modify the script to tell it where "migrate_passwd.pl" is and not to process or look for those other perl scripts. but how do i go about doing that and whcih script?

  6. #6
    Quote Originally Posted by peter View Post
    Try ./migrate_all_offline.sh instead.

    oh, that works. thanks!
    i get a few errors though, should i be concerned?

    [root@localhost migration]# ./migrate_all_offline.sh
    Creating naming context entries...
    Migrating aliases...
    Migrating groups...
    Migrating hosts...
    Migrating networks...
    Migrating users...
    Migrating protocols...
    Migrating rpcs...
    Migrating services...
    Migrating netgroups...
    Importing into LDAP...
    Migrating netgroups (by user)...
    sh: /etc/netgroup: No such file or directory
    Migrating netgroups (by host)...
    sh: /etc/netgroup: No such file or directory
    Preparing LDAP database...
    str2entry: invalid value for attributeType objectClass #0 (syntax 1.3.6.1.4.1.1466.115.121.1.38)
    slapadd: could not parse entry (line=71)
    Migration failed: saving failed LDIF to /tmp/nis.3895.ldif

  7. #7
    i managed to fix the errors above: i just stopped ldap service, and ran migrate_all_offline.sh again and no errors.

    i went ahead and start the service again, then on the client side, i configured ldap.conf and ran authconfig-tui. when tried to assign ownership to ldapuser, i get an error..

    [root@localhost ~]# chown -R ldapuser:users /home/ldapuser
    chown: 'ldapuser:users': invalid user

    does this mean /etc/passwd hasn't migrated properly? any ideas on how i can solve this problem?

    thanks.

  8. #8
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    It probably means that you didn't create the ldap user beforehand

    My sites:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  9. #9
    Quote Originally Posted by peter View Post
    It probably means that you didn't create the ldap user beforehand
    thanks peter. im pretty sure i created the user beforehand on the server. i followed the tutorial to a tee. i tried the chown command on another user on the server that existed before i started this project and it gave me the same error. i even reinstalled linux on both machines and redid the tutorial and still could not get pass this error. i googled around but could not get a solution.

  10. #10
    Hello,

    I have same problem like blankie's problem. When I tried to chown ldapuser command , I get same error message on client computer . How to solve this problem ?

Similar Threads

  1. ldap
    By LinuX_Z in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 08-20-2007, 08:29 AM
  2. LDAP problem
    By frog3d in forum Redhat / Fedora
    Replies: 0
    Last Post: 05-03-2007, 04:21 PM
  3. LDAP help.....
    By pushpraj nimbalkar in forum Linux - General Topics
    Replies: 1
    Last Post: 07-17-2006, 11:55 AM
  4. Connecting an external LDAP browser to SUSE LDAP
    By vmarco in forum Linux - General Topics
    Replies: 1
    Last Post: 02-16-2005, 07:00 PM
  5. LDAP Help
    By Ashcrow in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 07-28-2004, 03:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •