Results 1 to 2 of 2

Thread: Internet not working properly after ADSL2+ upgrade

  1. #1

    Internet not working properly after ADSL2+ upgrade


    My ISP (Demon Internet) recently upgraded my ADSL service to ADSL2+. Since then (at least, I noticed it around the same time and I don't believe the timing is just a coincidence) I'm having huge problems accessing the internet.

    After I put the URL in the address box it just says "contacting <server>" in the status bar and doesn't bring up the page. Occasionally it may do a redirect (e.g. from just the domain name to the initial landing page), or if after some time I hit stop I might see part of the page text with no styling or images. But most of the time it just goes off and eventually displays a message saying the server is not responding.
    RealAudio is also playing up. Most of the time it doesn't start playing the stream (eventually producing an error saying it can't contact the server). Occasionally (say once in a dozen or more attempts) it may start playing, but drops out again part way through.
    Mail (POP3) also appears to be having problems. Although I do still seem to be receiving it, most of the time when I check /var/log/mail it appears to have stalled while connected to the mail server. Even when it is receiving the messages, I think it must be running slowly and sometimes timing out rather than completing normally (i.e. without sending the final QUIT command) as I'm receiving duplicate copies of mail, several in some cases.

    At first I thought maybe it was my netbook's wifi connection playing up (sometimes it seems to lose the DHCP-assigned IP address or just loses the connection for no obvious reason (but reconnects okay again after about half a minute). So I tried connecting it into a spare ethernet port on the router and switching off the wifi, but it still behaved the same way.

    So then I thought maybe it was something corrupted in the netbook's linux (linpus) installation. But I found that my desktop machine (an old opensuse installation) was also behaving this way. It's that desktop machine that usually fetches the email. Also, I recently bought a replacement for the desktop machine and put a fresh, clean installation of Ubunto 9.04 on it; that also has the same problems surfing the net, and gives errors when trying to download security updates & additional packages. So I don't think it's a corrupt OS.

    So I thought maybe it's the ADSL router (which is old enough it doesn't support ADSL2+ anyway), or something about the upgraded connection at fault. But one of Demon's tech support guys has taken a look at things from their end and said the connection is coming up okay and he could see packets flowing across it. Also, when I run netstat on my machines, it shows a number of ESTABLISHED tcp connections, so it seems like the basic connectivity is okay.

    I took the netbook into work and connected up to the public wifi network there, and it works perfectly. I also borrowed a laptop from work and connected it to my home WLAN and that too appears to be working just fine! (I'm using it to post this message) The main difference, and the reason I'm posting here, is that machine (which works) runs Windows XP while all of mine (which don't) are running various flavours of linux...

    So I'm reaching the conclusion it's something about linux that isn't playing nicely with the upgraded connection. Unfortunately the support guy I was talking to didn't "know anything about unix", and couldn't suggest anything beyond checking my firewall. Okay, been there done that - there isn't one because there are no ports open/forwarded on the WAN side of the router anyway; besides, 1) it'd be a pretty screwed firewall setup that dropped packets for established (according to netstat) connections, 2) if that were the case I'd expect to get nothing at all back when occasionally it seems to be receiving little bits, and 3) everything was working perfectly a month ago and I've not changed anything in the setup since then.

    I found an FAQ on the Ubuntu site suggesting "slow web browsing in firefox" may be due to IPv6 DNS requests. But I don't think that's the problem since 1) I've tried setting network.dns.disableIPv6 to false in about:config and it makes no difference, 2) other browsers & services are also being affected, and 3) while 'ip a | grep inet6' shows the desktop machines have IPv6 support installed, that command returns nothing on the (Acer Aspire One) netbook so it doesn't appear to (don't see any mention of ipv6 in 'lsmod' either, unless it's called something else on the AA1). Besides, on the desktop machines 'dig AAAA <servername>' returns something immediately rather than timing out, so the "real reason for the problem" mentioned in that FAQ doesn't appear to apply anyway. I did try 'ifconfig eth0 inet6 del <ipv6address>/<prefixlength>' just in case, but that didn't make any difference either.

    So now I'm running out of ideas. I've got a new router on the way that does support the faster ADSL2+, just in case that has any effect. In the meantime, and in case I still have the problem once that's installed, is there anything else people can suggest for me to check/try?

    Here's hoping it's something relatively simple...


  2. #2
    Advisor beezlebubsbum's Avatar
    Join Date
    May 2004
    maybe you need to assign the dns server manually? I find that sometimes that my net drops and assigning the ip manually fixes it. Just a suggestion?

Similar Threads

  1. Internet, e-mail not working... except on LJr.
    By Lixus Looser in forum Linux - General Topics
    Replies: 17
    Last Post: 01-03-2005, 01:54 AM
  2. My ISP is not working properly.. What should i do??
    By in forum Windows - General Topics
    Replies: 10
    Last Post: 01-08-2004, 12:47 AM
  3. Replies: 0
    Last Post: 01-08-2004, 12:34 AM
  4. Are unread marks working properly??
    By SwampDonkey in forum Announcements and Suggestions
    Replies: 1
    Last Post: 02-19-2003, 08:58 PM
  5. MS is working on internet explorer for UNIX
    By Twelveguage in forum General Chat
    Replies: 14
    Last Post: 12-07-2001, 11:37 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts