Results 1 to 8 of 8

Thread: auto mount file system

  1. #1

    auto mount file system


    How do i enable auto mount file system in my system? I am using linux ver4

  2. #2
    Um...need a clarify things a bit here. Since Linux normally would refer to the kernel and that would normally be 2.6.x I'm not following you on the linux ver4...there's no such thing.

    What you should have is a distrobution/flavor of Ubuntu,Fedora,Suse,Slax,Gentoo...etc. etc.

    Automounting is handled by different way...sometimes by the desktop environment ...something line Gnome,KDE,XFCE,Enlightenment. etc.

    I use Gnome and automounting is handled via the gnome-volume-manager which is controlled from gconf-editor.

    There are other ways depending on what your actually running.

  3. #3
    Join Date
    Dec 2004
    It would be easier if you let us know what you are trying to achieve (e.g. automounting homedirs, cdrom etc). Then someone can point you to the right direction. HTH

  4. #4
    When i insert my pendrive or cd, each time i have to mount it manually and it it doesnot auto mount, i want it to auto mount when i insert the cd or pendrive.

  5. #5
    I would still like to know more about what distro for more specific help..but..

    You could try something like this in your /etc/fstab

    /dev/sda1 /mnt/usbdrv auto auto,user,rw,exec 0 0

    where /dev/sda1=path to the device and /mnt/usbdrv is the mount point.

  6. #6
    Join Date
    Dec 2004
    Like Witchlight said, telling us your distro would be helpful. If you have either the latest SuSE or Fedora, read about 'halmount'. HTH

  7. #7
    I use redhat 4, Linux 2.6.9-5.EL which was distributed along with my system

  8. #8
    Ok, So I haven't used Redhat but a quick search tells me that Redhat likes you to use autofs for automounting.

    Check and see if its installed.
    I was able to find a great guide for configuring autofs here

    The other option is since Redhat does use gnome as its desktop you maybe able to let the gnome-volume-manager handle the automounting. If you go this way check to make sure that gnome-volume-manager is installed. If it is great. If its not put it in.

    Use a terminal and run gconf-editor

    Then navigate to Desktop-->gnome-->volume-manage

    make sure that automount_drives and automount_media are checked.

    Also from the main menu System-->Preferences-->Removable Drives and Media make sure everything you want is checked.

    Good luck.

Similar Threads

  1. How to revert my file modes of /etc file system
    By vesskrishna in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 10-26-2009, 05:24 AM
  2. Replies: 1
    Last Post: 03-15-2008, 09:56 AM
  3. how to make auto mount CD in Linux.
    By rameshs in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 10-09-2006, 12:31 PM
  4. how to make auto mount CD in Linux.
    By rameshs in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 10-09-2006, 12:21 PM
  5. manually mount NFS file system.
    By smith786 in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 09-24-2005, 03:06 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts