Results 1 to 9 of 9

Thread: unable to access internet on RHEL

  1. #1

    unable to access internet on RHEL

    I installed RHEL 5.0 on my home PC today. I use a broadband connection at home for internet(pppoe). iam not able to access internet using the mozilla on RHEL. i am able to ping to the gateway, ping to yahoo website command # host yahoo website address resolves the ip and the reverse too. i have checked the entries in all the network conf files tht am aware of, but still scratching my head over this.
    additionally, i can also access my roter page ( on mozilla
    but trying any website on mozilla returns with the page is not found. suprisingly(actually annoying) the redhat website works absolutely fine. please help!

  2. #2
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    You may have set your browser to use a proxy that doesn't exist, or you may have an incorrectly configured firewall running on your system.

    It could be something else too...

  3. #3
    there are no proxy settings in the browser
    linux firewall has been disabled - i havent installed any other firewall
    selinux is also not enforcing

  4. #4
    just a suggestion. i would try resetting the modem. then run the command (service network restart) at the root. when you say redhat website works fine, are you talking about or file://..redhat.. which doesn't need internet connection.

  5. #5
    yes was working but not anymore... just few more updates
    i confirmed that if i open the brower firefox, enter the ip address of any website - i tried google, that is http://(ip address of google) it loads the page. but am not able to access when i type in the web address. so i concluded the issue could be with dns resolving.
    i checked my /etc/resolv.conf and it has the correct entries for nameservers as per suggested by ISP
    i checked the /etc/nsswitch.conf - it was "hosts files dns" and i changed this like to "hosts dns files" but still unable to access
    i have also checked /etc/sysconfig/network-scripts/ifcfg-eth0 file and it has all the correct info.
    i downloaded firefox and hoping thats the latest version, but was not successful to install due to an error message about an unavailable library file... didnt want to start a new issue, just not to complicate things, but i somehow want to resolve my internet access issue
    i suspect one of the flat files is causing this here. have set no proxy on the firefox - connect direct to the internet... please help me if you can provide any solution

  6. #6
    does it resolve correctly with dig is your resolv.conf automatically populated by the modem with your ISP's nameserver? if a router is connected, you can double-check the correct ISP nameserver by going into your router under status tabs via depending on your router's make. check for anything suspicious in the tail -30 /var/log/messages. one alternative is to configure your own DNS server.

    you can use a text-based browser like elinks as an alternative to firefox to test your connection. just do.. elinks or elinks

  7. #7
    i have not tried dig yet. will try that and update you! resolv.conf is not automatically populated, i did add the entries myself. i contacted the ISP and tried with different nameservers as per their advise but none of them works. dmesg | tail doesnt produce anything suspicious
    am in the process of configuring my own dns server now, but again i have to set the ISP's nameserver as the master server, so again am doubtful if that will work
    elinks dont work too. i dont understand your advise of "if a router is connected, you can double-check the correct ISP nameserver by going into your router under status tabs via depending on your router's make" could you please explain a little more?

  8. #8
    that's just how to find the isp's nameserver ip addresses by going into the router and viewing the information under the status tab. but, since you've already have the nameserver ip addresses from your isp, then you wouldn't need to do that.

    as for the dns issue, im afraid i've ran out of ideas. but you can ask the guys at if they can help. good luck.

  9. #9
    hey... thank you for the help. i will check with them, anyways i have planned to reinstall from scratch over the weekend. will let you know! thanks again!

Similar Threads

  1. Unable to access remote machine after network upgrade
    By n.dave in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 12-06-2008, 05:36 AM
  2. prblem in RHEL regarding internet connection
    By alokatzenith in forum Redhat / Fedora
    Replies: 1
    Last Post: 01-26-2007, 06:38 AM
  3. Unable to Access Hotmail
    By trickster in forum Linux - General Topics
    Replies: 9
    Last Post: 10-31-2004, 07:50 PM
  4. unable to access the internet
    By saha in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 03-17-2004, 07:10 AM
  5. Unable to access websites
    By stryder144 in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 11-19-2002, 05:24 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts