Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
yum libpackagekit-glib.so.10 error in Fedora 10
Results 1 to 2 of 2

Thread: yum libpackagekit-glib.so.10 error in Fedora 10

  1. #1

    yum libpackagekit-glib.so.10 error in Fedora 10

    Got this error when using yum update on fedora 10

    Code:
    # yum -y update
    Loaded plugins: refresh-packagekit
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: libpackagekit-glib.so.10 for package: gnome-packagekit
    ---> Package PackageKit-glib.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-yum.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-udev-helper.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-gstreamer-plugin.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-yum-plugin.i386 0:0.3.11-4.fc10 set to be updated
    --> Finished Dependency Resolution
    gnome-packagekit-0.3.9-8.fc10.i386 from installed has depsolving problems
    --> Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (installed)
    Error: Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (installed)
    #
    Looked around on the message boards and they suggested doing all sorts of file edits. I just decided to remove the Packagekit package and then use yum to reinstall it and then everything was OK in Fedora Core 10.

    Code:
    # sudo rpm -e PackageKit gnome-packagekit PackageKit-glib \
    PackageKit-udev-helper  PackageKit-yum PackageKit-gstreamer-plugin \
    PackageKit-yum-plugin
    # yum -y install PackageKit
    Thought you'd all like to know!

  2. #2
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    I got the same thing

    Code:
    [root@server ~]# yum -y update
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: libpackagekit-glib.so.10 for package: gnome-packagekit
    ---> Package PackageKit-yum.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-glib.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package PackageKit-udev-helper.i386 0:0.3.11-4.fc10 set to be updated
    ---> Package crontabs.noarch 0:1.10-25.fc10 set to be updated
    ---> Package PackageKit-yum-plugin.i386 0:0.3.11-4.fc10 set to be updated
    --> Finished Dependency Resolution
    gnome-packagekit-0.3.9-8.fc10.i386 from installed has depsolving problems
      --> Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (installed)
    Error: Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (installed)
    [root@server ~]# 
    [root@server ~]# rpm -e PackageKit
    error: Failed dependencies:
            PackageKit = 0.3.9-4.fc10 is needed by (installed) PackageKit-yum-0.3.9-4.fc10.i386
            PackageKit is needed by (installed) PackageKit-yum-plugin-0.3.9-4.fc10.i386
            PackageKit = 0.3.9-4.fc10 is needed by (installed) PackageKit-glib-0.3.9-4.fc10.i386
            PackageKit >= 0.3.8 is needed by (installed) gnome-packagekit-0.3.9-8.fc10.i386
            PackageKit is needed by (installed) PackageKit-udev-helper-0.3.9-4.fc10.i386
    [root@server ~]#


    I removed the packages OK

    Code:
    [root@server ~]# rpm -e PackageKit PackageKit-yum \
     PackageKit-yum-plugin  PackageKit-glib gnome-packagekit PackageKit-udev-helper



    But yum failed:

    Code:
    # yum -y install PackageKit PackageKit-yum \ 
    PackageKit-yum-plugin PackageKit-glib gnome-packagekit PackageKit-udev-helper


    It looks like gnome-packagekit is the culprit. Using yum to install the packages without gnome-packagekit was OK.

    Code:
    gnome-packagekit-0.3.9-8.fc10.i386 from fedora has depsolving problems
      --> Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (fedora)
    Error: Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (fedora)


    Here's what happens when I use yum to just install that package:

    Code:
    [root@server ~]# yum -y install gnome-packagekit
    Loaded plugins: fastestmirror, refresh-packagekit
    Loading mirror speeds from cached hostfile
     * fedora: mirror.stanford.edu
     * updates: mirrors.cat.pdx.edu
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    ---> Package gnome-packagekit.i386 0:0.3.9-8.fc10 set to be updated
    --> Processing Dependency: libpackagekit-glib.so.10 for package: gnome-packagekit
    --> Finished Dependency Resolution
    gnome-packagekit-0.3.9-8.fc10.i386 from fedora has depsolving problems
      --> Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (fedora)
    Error: Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.i386 (fedora)
    [root@server ~]#

    My sites:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Similar Threads

  1. Oracle installation error on Fedora core 5 32 +bit
    By tech291083 in forum Redhat / Fedora
    Replies: 2
    Last Post: 03-31-2007, 10:31 AM
  2. GLIB - Fedora - I'manewbie
    By clayharryman in forum Linux - General Topics
    Replies: 4
    Last Post: 02-10-2005, 02:49 AM
  3. rpm installation error in fedora
    By Extro in forum Linux - General Topics
    Replies: 8
    Last Post: 01-21-2005, 07:30 PM
  4. Error installing packages under Fedora
    By in forum Linux - Software, Applications & Programming
    Replies: 21
    Last Post: 03-04-2004, 02:17 PM
  5. MOVED: Error installing packages under Fedora
    By trickster in forum General Chat
    Replies: 0
    Last Post: 01-22-2004, 08:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •