Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Upgrading to Fedora 10

  1. #1
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882

    Upgrading to Fedora 10

    I'm upgrading now!

    • To upgrade go to the upgrade FAQ page
    • You have to remove the fedora-release and fedora-release-notes rpms using:

    Code:
     rpm -e --nodeps <package 1> <package 2>
    • The new fedora-release files are now named:

    Code:
    generic-release-*.noarch.rpm
    • Go to the download mirrors to get your packages. The link in the FAQ is outdated

    So far the rest looks good!

  2. #2
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    I'm getting these types of messages

    nspr-devel-4.7.0.99.2-2.fc9.i386 from fedora has depsolving problems
    --> Missing Dependency: nspr = 4.7.0.99.2-2.fc9 is needed by package nspr-devel-4.7.0.99.2-2.fc9.i386 (fedora)
    nss-devel-3.11.99.5-2.fc9.i386 from fedora has depsolving problems
    --> Missing Dependency: nss = 3.11.99.5-2.fc9 is needed by package nss-devel-3.11.99.5-2.fc9.i386 (fedora)
    Error: Missing Dependency: nss = 3.11.99.5-2.fc9 is needed by package nss-devel-3.11.99.5-2.fc9.i386 (fedora)
    Error: Missing Dependency: nspr = 4.7.0.99.2-2.fc9 is needed by package nspr-devel-4.7.0.99.2-2.fc9.i386 (fedora)

  3. #3
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Did you uninstall the fedora-release* rpms first and then install the new generic-release ones?

    Also try this:

    Code:
    yum -y clean all
    yum -y makecache
    Making a new cache may help out.

  4. #4
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    Thanks! I got much further, but now I get this.

    avahi-0.6.11-3.fc5.i386 from installed has depsolving problems
    --> Missing Dependency: libcap.so.1 is needed by package avahi-0.6.11-3.fc5.i386 (installed)
    Error: Missing Dependency: libcap.so.1 is needed by package avahi-0.6.11-3.fc5.i386 (installed)

    I upgraded from fc5 some years ago, now it's haunting me.

    Code:
     
    [root@web-001 yum.repos.d]# rpm -e avahi-0.6.11-3.fc5
    error: %postun(avahi-0.6.11-3.fc5.i386) scriptlet failed, exit status 1
    [root@web-001 yum.repos.d]#
    What's up with this error?

  5. #5
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Try this:

    Code:
    # rpm -e --nodeps --allmatches --noscripts avahi-0.6.11-3.fc5

  6. #6
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    Great! Deleting my FC5 RPMs now!

  7. #7
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    It's looking good! Trying an upgrade from Fedora Core 8 to Fedora 10. Fingers crossed...

  8. #8
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    How do you update the perl modules to the latest version now?

  9. #9
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Code:
    # perl -MCPAN -e 'CPAN::Shell->install(CPAN::Shell->r)'

  10. #10
    Junior Member tuxette's Avatar
    Join Date
    Jan 2006
    Posts
    60
    Thanks, now I'm getting this when I do :

    Code:
    #yum -y update
    Transaction Check Error:
    file /usr/sbin/sysreport from install of sysreport-1.4.4-1.noarch conflicts with file from package sos-1.8-2.fc10.noarch
    file /usr/share/sysreport/functions from install of sysreport-1.4.4-1.noarch conflicts with file from package sos-1.8-2.fc10.noarch

Similar Threads

  1. Dual Boot Ubuntu / Fedora - Installing Fedora First
    By peter in forum Redhat / Fedora
    Replies: 2
    Last Post: 12-17-2010, 09:01 PM
  2. Upgrading to Fedora 11 - FC11 Problem
    By peter in forum Linux - General Topics
    Replies: 4
    Last Post: 06-14-2009, 06:24 PM
  3. Upgrading to Fedora Core 3 - simple question
    By DamselNDistress in forum Linux - General Topics
    Replies: 12
    Last Post: 03-04-2005, 03:20 PM
  4. Windows XP cannot see Fedora System, but Fedora can read XP
    By rrushing in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 01-30-2004, 04:32 AM
  5. Upgrading from Rh 7.1 to RH 7.2
    By EL-Newbie in forum Linux - General Topics
    Replies: 3
    Last Post: 03-06-2002, 05:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •