Results 1 to 2 of 2

Thread: Configure X server for SiS 530

  1. #1
    Join Date
    Apr 2002

    Configure X server for SiS 530

    Well, I've been watching these posts and searching this and LinuxJunior, etc., but I'm still spinning my wheels ... so, time to break down and ask for help.

    The box:
    PCChips M598 mobo
    Sis 530 video (onboard w/8Mb shared mem)
    256Mb RAM
    CMedia 8330 audio (onboard)
    1.3Gb Quantum (1 partition Win2K /hda1)
    6.4Gb Fujitsu (3 partitions-/hdb1=swap 128Mb
    /hdb3=linux 3Gb
    Acer ATAPI 50x CDROM

    I installed Win2K on HDD #1 first.

    Then attempted install from Caldera OpenLinux 2.2 CD - grey screen during VGA probe (apparently?).

    Then tried the LILO install from install floppies - again fail during display adapter probe (?).

    Then partitioned and installed using LISA install from floppy. YES!! Got a boot, root user and standard user setup. Tried configuring xf86config using the XF86_SVGA server, which according to, was appropriate for SiS530. Got nothing during startx.

    Then downloaded xsis.rpm from SiS download site, ran "rpm -i --nodeps xsis.rpm", "xf86config" and "startx" followed install directions and again, failed.

    I've re-ran the LISA install at least 3 times as it's the only way I've found thus far to achieve an OS (albeit, command line only). I'm sure my problem has something to do with the xf86config settings for the SiS 530 video, but can't seem to get things 'proper' - always achieve a grey screen during a LILO boot.

    Since I think I just need to keep tweaking the xf86config setup (maybe upgrade to the newest release of XFree86??), but can only get there during the FULL LISA install, I tried creating a boot disk rather than run another LISA install. However, the only bootable options I have run LILO and I can't seem to simply boot to the bootable image (kernel?) I previously installed to /hdb2. Is there a way to start LILO and call the /hdb2 boot? If I can get another command line boot, I think I can create a bootable floppy (dd if=/boot/vmlinux of=/dev/fd0 bs=8192 ... or the like).

    Anyone able to get me off this merry-go-round?? ... and through my adapter setup?

    Thanks in advance.

  2. #2
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001

    Re: Configure X server for SiS 530

    First of all, your Caldera 2.2 is too old .....

    For latest driver support, get the latest versions... If you like Caledra, get their latest ( OpenLinux 3.0 IIRC ) or Red Hat. Red Hat seems to be doing better in getting stuff installed right out of the box for me. Even my ATI Rage64 had been good at getting it installed which I've had a hell of a hard time with Caldera and Debian.

    If you want the command line and want to boot the one that you already installed ( rather than the one from install disk ), do a "rescue root=hdbx" where x = your boot partition. That will get you to boot off from that Linux installation kernel.

    And if you want the command line during the installation, do alt+control+F1 or F2 and that will get you to limited basic CLI to get it going ....

    HTH ...

Similar Threads

  1. Unable to configure SFU3.5 for Windows 2008 server
    By vakkarao in forum Redhat / Fedora
    Replies: 0
    Last Post: 03-21-2012, 12:46 PM
  2. How to configure squid server in debian 6
    By gyan in forum Ubuntu / Debian
    Replies: 0
    Last Post: 09-26-2011, 07:44 AM
  3. how to configure jabber chat server on fedora 14
    By devarsh in forum Ubuntu / Debian
    Replies: 0
    Last Post: 09-24-2011, 09:53 AM
  4. help me to configure DNS server
    By ringque in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 09-02-2009, 06:04 PM
  5. how to configure Email Server
    By alharbi in forum Redhat / Fedora
    Replies: 9
    Last Post: 12-28-2003, 06:35 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts