Results 1 to 5 of 5

Thread: relocation error:

  1. #1

    relocation error:

    when trying to start my gnomad prog for the nomad jukebox i get this error:

    ______________________________________________

    relocation error: /usr/lib/libid3-3.8.so: undefined symbol: cerr

    ______________________________________________

    i was thinking this isnt related to the jukebox program but then again i dont know.

    SD

  2. #2

    Re: relocation error:

    This is just a guess and maybe you already know this but it looks like you are missing library files for the prog. Has it ever worked?

  3. #3

    Re: relocation error:

    nah, i got the libraries is says it needs which are basically 2 files. i even used an older rpm that didnt need either with the same effect. i only got the gnomad prog the other day so it hasnt worked since i got it.

    SD

  4. #4

    Re: relocation error:

    ok, my fault. i recompiled and got it installed. but i feel im shit out of luck because i dont know if anyone here uses the nomad jukebox.
    (drake 8.2). i got the latest version of gnomad and i got libnjb and what not. i DO have an hp scanjet 2200 usb scanner which isnt supported although drake detected it and says it set it up (xsane says no devices found) anyhow....

    when i run gnomad it opens for a flash and says:
    ______________________________ ________________

    GLib-CRITICAL **: file gscanner.c: line 677 (g_scanner_input_file): assertion `input_fd >= 0' failed.
    Segmentation fault
    [sd@localhost sd]$
    ____________________________________________


    anyone have a clue?

  5. #5

    Re: relocation error:

    On the face of it (sorry, I have no idea what gnomad does), it looks like it is having trouble opening up your scanner device for input. This manifested itself in the creation of a negative file descriptor.
    This, I guess, is related to the general problems you are having with the device (xsane not being able to identify it)
    It would appear that gnomad has a bug whereby it is not correctly trapping the failed attempt to open the device (and give a nice friendly message saying so) as the error message you are getting is being displayed during execution of a library routine.

Similar Threads

  1. IE Error.
    By Balaji_haridoss in forum Windows - General Topics
    Replies: 0
    Last Post: 03-12-2007, 05:29 AM
  2. Internal Server Error - ASP error
    By Jason Lu in forum Windows - General Topics
    Replies: 2
    Last Post: 02-18-2005, 09:45 AM
  3. Has anyone seen this error before?
    By datamike in forum Linux - General Topics
    Replies: 13
    Last Post: 12-24-2003, 03:15 AM
  4. APT-GET PGP Error
    By JockVSJock in forum Linux - General Topics
    Replies: 7
    Last Post: 05-19-2003, 01:19 AM
  5. apt-get error
    By JockVSJock in forum Linux - General Topics
    Replies: 6
    Last Post: 05-07-2003, 07:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •