Written by ::: Compunuts
Last edited by ::: -- Compunuts 01:52, 7 May 2006 (PDT)
(Transferred from Wiki by Peter)

This document assume that you have Mozilla up and running and you wanted to have Shockwave Flash player plug-in to work with Mozilla Browser. I tested with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/2001090 1 on Red Hat Linux 7.2 but (almost) all Linux version and (almost) all current Mozilla versions should work as well.

  • First, you need to download Shockwave Flash plug-in. Go to Adobe Macromedia Linux page and download it to your user directory. For easier sake, I use ~/download/flash .


  • Then go to your downloaded directory.

Code:
cd ~/download/flash
  • Then do,

Code:
ls
  • You should see flash_linux.tar.gz in the directory. (This is sample file name. The real file name will depends on the version of the file being released by the time of you reading this).Now, you need to unpack the file. Do,

Code:
tar -xvzf flash_linux.tar.gz
  • That should create a directory called flash_linux ( or something similar ).


  • From this point on, there are two ways you can do to install it.

The easy way

  • Navigate to this directory and from the command line type ./flashplayer-installer to run the installer (Note: this can only be run from the command line). The installer will instruct you to shut down your browser(s).

That should do it. If not, do the following.
The hard way

  • Go to the directory. You will see two files called " libflashplayer.so and ShockwaveFlash.class" ( plus a README file or two ).


  • Copy those two files into Mozilla plug-in directory ( you need to be super user to do this ).

Code:
cp libflashplayer.so ShockwaveFlash.class /usr/lib/mozilla/plugins/
  • That's it and you are done. Now, let's verify whether Mozilla recognize your newly installed plug-ins.

Fire up your Mozilla browser, go to "Help" and then "About Plug-ins" tab ( or ) press "Alt+H+P" keys on your keyboard. Mozilla should lunch the plug-ins page and you should see yours there....