Results 1 to 3 of 3

Thread: Windows permissions issue, methinks..

Hybrid View

  1. #1
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Windows permissions issue, methinks..

    I have been using a USB <-> (P/S)ATA cable for some time to fix borked system installs, and from time to time I get oddball issues with regards to how the drive gets mounted. I have yet to figure this one out entirely.

    What happens is, generally the host is Vista Ultimate but sometimes XP Pro. The drive is an NTFS drive with XP Home on it usually. When I run a spyware or AV scan on the drive, it can read, but not write. If I redo the permissions, the permissions seemingly change, but get reverted to whatever it was when I started out the whole endeavour.

    Any ideas where I can go to fix the stupid permissions issue? I was going to Properties, Permissions and giving everything R/W permissions to no luck on both the drive itself and the root folder.

    Thanks much!

    Oh BTW, the solution I have found that does work is mount it on linux, run an inferior AVG or NOD32 AV scan from there. Usually will get the system booting to do a native NOD32 scan. Long way to do what to me should be much simpler.

  2. #2
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760
    Figured it out. A friend mentioned to try rebooting, after laughing at him, I then said aww fuck it. Gotta try anything at this point.

    Well it worked.

    For those that run into the same issue, here is what you need to do:

    XP/Vista:

    1)Attach drive via usb or to IDE/SATA chain
    2)After booting log in and modify drive permissions to allow for your user to have sufficient permissions
    3)Reboot

    (Vista Only)
    3a) Run AV Tool as Administrator

    4)Scanning should work fine now.
    5)When finished shut down, and disconnect drive
    6)Reset permissions back to normal within the formerly infected OS
    7)Run AV tool native to system.

    Should be done and ready to rock.
    HTH. I was only missing the rebooting part, so I am not sure who else ran into issues here as well.

  3. #3
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    I've never had problems with USB attached ATA drive? Are you scanning a system / boot disk after a virus infection?

Similar Threads

  1. TTY permissions problem
    By mcdougrs in forum Linux - General Topics
    Replies: 4
    Last Post: 06-28-2003, 12:58 PM
  2. Partition Permissions
    By saintNiX in forum Linux - General Topics
    Replies: 11
    Last Post: 11-11-2002, 02:27 AM
  3. Permissions
    By ASCI_Blue in forum Linux - General Topics
    Replies: 1
    Last Post: 11-09-2002, 07:36 PM
  4. cd permissions
    By deepfreeze in forum Linux - General Topics
    Replies: 6
    Last Post: 08-29-2002, 03:28 PM
  5. Permissions and rights
    By chadm1967 in forum Linux - General Topics
    Replies: 4
    Last Post: 12-04-2001, 02:33 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •