Results 1 to 6 of 6

Thread: WiFi not working with BCM94311

  1. #1

    WiFi not working with BCM94311

    Hi all,

    I am a newbie to Linux. I had earlier successfully installed OpenSuse 10.3 and Wi-Fi Rocks on my Dell laititude ( out of the box). However, I am having tons of difficulties with the broadcom chip set my compaq V3424au has.

    I cannot see the wireless network I have at home. The light on the card is not turning blue. It has always remained blue. I went through other forums and tried doing it via bcm cutter and ndiswrapper. Both haven't worked for me till now.

    Below is the output.

    dmesg | grep -i ndis has the following output

    ndiswrapper version 1.53 loaded (smp=yes, preempt=no)
    ndiswrapper : driver bcmwl5 ( Broadcom, 10/12/2006, loaded
    ndiswrapper: using IRQ 11
    wlan0: ethernet device 00:1a:73:8e:9e:63 using NDIS driver: bcmwl5, version: 0x4640f05, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4311.5.conf
    wlan0: encryption modes supported: WEP,TKIP with WPA, WPA2 ..usbcore: registered new interface driver ndiswrapper

    lspci -v -v
    01:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)
    Subsystem: Hewlett-Packard Company Unknown device 1375
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at b3000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 PME-Enable- DSel=0 DScale=2 PME-
    Capabilities: [58] Vendor Specific Information
    Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    Address: 0000000000000000 Data: 0000
    Capabilities: [d0] Express Endpoint IRQ 0
    Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
    Device: Latency L0s <4us, L1 unlimited
    Device: AtnBtn+ AtnInd+ PwrInd-
    Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
    Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
    Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
    Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
    Link: Latency L0s <4us, L1 <64us
    Link: ASPM L0s L1 Enabled RCB 64 bytes CommClk- ExtSynch-
    Link: Speed 2.5Gb/s, Width x1

    Any help on it please.
    Last edited by quicksilverm26; 06-16-2008 at 09:23 AM.

  2. #2
    Join Date
    Feb 2008
    Install OpenSuse 11. The Broadcom chipset will be recognised. Now add the most important repositories. Search now for the Broadcom drivers (Yast - Software). Once installed your Wifi will work.

  3. #3
    to apmob:

    hi iam new to linux and i have installed opensuse 11.0 i too use a BCM 94311 wlan card i don't know how to activate it
    could you also tell me how to set the proxy address

  4. #4

    Help opensuse11.0 BCM94311MCG

    i use a opensuse11.0 but i dont c my networks what should i do?

  5. #5
    I got my BCM94311 wireless card working on an HP DV6000 laptop using the guide here:


  6. #6
    Join Date
    Feb 2008

    Wifi not working with BCM94311

    For OpenSuse 11.0: add the "Packman" repository. Go to "Yast -Software" and search for "Broadcom". Install the b43 driver and restart.
    So far for a working driver, but do'nt forget to install the network card: (E)SSID - WEP, WPA or WPA2 encryption + passwords.

Similar Threads

  1. fedora8+wifi+dhcp not working suddenly
    By hopper in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 04-19-2008, 05:38 AM
  2. WiFI Problem
    By carmelovazzana in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 02-29-2008, 08:54 AM
  3. regarding wifi
    By lovewadhwa in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 09-10-2006, 08:46 AM
  4. WiFi on the road
    By Schotty in forum General Chat
    Replies: 8
    Last Post: 10-07-2005, 03:22 AM
  5. WiFi
    By BJ250 in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 12-31-2002, 02:00 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts