Results 1 to 3 of 3

Thread: Problem starting mysql conflicts with the RPM "mysql-5.0.27-1.fc6"

  1. #1

    Problem starting mysql conflicts with the RPM "mysql-5.0.27-1.fc6"


    Good morning!!

    I tried starting mysql from /usr/local, the location where i installed mysql

    but after executing this command " bin/mysqld_safe --user=mysql &"

    Its coming like mysql is starting from /var/lib/mysql, which i never mentioned

    and message coming like "STOPPING server from pid file /var/run/mysqld/"

    But there is no directory named mysqld or file in /var/run location.

    I have installed some rpms from the website for skype installation, i think this problem starts after the installation of those rpms.

    Terminal output for your reference :

    [root@localhost ~]# cd /usr/local
    [root@localhost local]# cd mysql1
    [root@localhost mysql1]# bin/mysqld_safe --user=mysql &
    [1] 3485
    [root@localhost mysql1]# Starting mysqld daemon with databases from /var/lib/mysql
    STOPPING server from pid file /var/run/mysqld/
    071022 10:02:31 mysqld ended

    For mysql problem, i post a thread to discussion forum in "mysql" website and they replied as follows

    "Chances are something has overwritten your /etc/my.cnf file. You may want to check and re-edit it. You can also check to see if there is a copy left behind with a .rpmsave extension.

    You should also use 'rpm -qf /etc/my.cnf' to check if there is anRPM that owns the replaced file, as it may have added other items thatare going to cause you problems."

    I checked for "my.cnf" file in /etc/, The file exist and i am attaching the same for your reference.But the "my.cnf" file is not there in Bhavani's machine. so i renamed the file and tried starting mysql again and the terminal displays output like

    "[root@localhost mysql1]# Starting mysqld daemon with databases from /usr/local/mysql1/data
    STOPPING server from pid file /usr/local/mysql1/data/
    071022 13:01:09 mysqld ended"

    In that reply, they asked to check for rpm file with the command "rpm -qf /etc/my.cnf".when i run that command i got
    "[root@localhost ~]# rpm -qf /etc/my.cnf

    Can u please suggest me a solution to this problem.

    Thank you
    Best Regards

  2. #2
    I'm slightly confused as to why you are executing it from a bin folder in a directory named mysql1. You should be able to execute from root's path, but also, you should be able to start it as a service. Try starting as a service. I'm thinking that problem exists from the present working directory that you are starting it from, but then again, I don't have a FC6 box in front of me.
    arrogance breeds ignorance

    Screaming Electron, Full of BSD Goodness

  3. #3
    Hi ,

    Thank you very much for your prompt reply, mysql is working for me now as i deleted the "my.cnf" fime from /etc/ and resinstalled the mysql software.

    Thank You
    Best Regards

Similar Threads

  1. "TELNET-SERVER" connection me to solve
    By ringque in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 03-02-2010, 08:33 PM
  2. problem with "logrotate"
    By dvrmc in forum Linux - General Topics
    Replies: 2
    Last Post: 11-23-2007, 07:17 AM
  3. "groupadd" and "tree" utilities are nowhere??
    By aromes in forum Redhat / Fedora
    Replies: 1
    Last Post: 10-05-2003, 03:50 AM
  4. Starting Mysql at boot
    By Poppo in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 03-21-2002, 02:46 PM
  5. Xlib:  extension "GLX" missing on display ":0.0".
    By ph34r in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 12-06-2001, 04:52 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts