Hello,
I've tried now for several hours to get my Zebra LP 2844 label printer to work with Linux and CUPS. I have tried with all of the drivers in CUPS (there are three; one EPL1, one EPL2 and one ZPL). I've checked so the printer works OK when it is connected to a windows machine and everything is OK, there is labels in it. It is connected to the Linux computer with an USB cable.

First I added the printer to cups, following the normal procedure. Then, when I click "print test page" I get the error "No pages found!". When I try to restart the test page print job the error changes to "/usr/lib/cups/filter/rastertolabel failed". Regardless of what driver I test with, and regardless of if I restart the printer.

To me it seams like it can't find any papers by first look (but I'm not good at these parts of linux). I really need help to fix this as the label printer is very important for me to be able to use so I really appreciate all help.. If you reply with a working solution and send me your Paypal email I might also send you some compensation : ) but I'm just an individual who is really frustrated about this issuse so I don't tell me to hire someone.

With CUPS in normal mode I get the following in the error log:
Code:
I [05/Oct/2007:22:06:21 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7942)
I [05/Oct/2007:22:06:23 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7943)
I [05/Oct/2007:22:06:28 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7944)
I [05/Oct/2007:22:06:28 +0200] Adding start banner page "none" to job 21.
I [05/Oct/2007:22:06:28 +0200] Adding end banner page "none" to job 21.
I [05/Oct/2007:22:06:28 +0200] Job 21 queued on "Zebra_LP2844_USB_1" by "root".
I [05/Oct/2007:22:06:28 +0200] Started filter /usr/lib/cups/filter/pstops (PID 7945) for job 21.
I [05/Oct/2007:22:06:28 +0200] Started filter /usr/lib/cups/filter/pstoraster (PID 7946) for job 21.
I [05/Oct/2007:22:06:28 +0200] Started filter /usr/lib/cups/filter/rastertolabel (PID 7948) for job 21.
I [05/Oct/2007:22:06:28 +0200] Started backend /usr/lib/cups/backend/usb (PID 7949) for job 21.
E [05/Oct/2007:22:06:28 +0200] PID 7946 (/usr/lib/cups/filter/pstoraster) stopped with status 127!
I [05/Oct/2007:22:06:28 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
E [05/Oct/2007:22:06:29 +0200] [Job 21] No pages found!
E [05/Oct/2007:22:06:29 +0200] PID 7948 (/usr/lib/cups/filter/rastertolabel) stopped with status 1!
I [05/Oct/2007:22:06:29 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
I [05/Oct/2007:22:06:30 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7950)
With CUPS in debug mode I get a lot of information from the error log:
(I couldn't add the whole error log here because the message would have been to big, but I hosted it on http://www.mediafire.com/?bbjljh9rhxh and http://www.desiload.com/download.php...9b0df4c95112ee so please view it there.)

Thanks in advance,
Oskar R