Hi all,

I'm trying to figure out how to install GCC 3.1 from source. I've tried several times to no avail. I'm a newbie to Linux, but I want to learn how to install apps from source. (I have read that the compiler would be the hardest thing for a newbie to install, so I wanted to figure out how.) I downloaded the full source tarball of GCC 3.1. I've read the documentation that comes with that several times (it's confusing, but I did it). So, I tried doing this:

$ mkdir gcc-build-3.1
$ cd gcc-build-3.1
$ ../gcc-3.1/configure --prefix=/home/x/Programs/gcc-3.1
$ make bootstrap
$ make prefix=/home/x/Programs/gcc-3.1 install

Now, to test out the compiler I have it compile a simple c++ program I wrote to output 'Hello.'. I type the following to compile and run the program:

$ /home/x/Programs/gcc-3.1/bin/g++ -o hello hello.cpp
$ ./hello

When I do that, I get the following:

error while loading shared libraries: libstdc++.so.4: cannot open shared object file: No such file or directory

Isn't that my standard c++ library? Why wasn't that installed? And how do I install it?

(BTW, I'm running Mandrake Linux 8.1 Standard Edition with GCC 2.96)