Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Getting madwifi, wpa_supplicant and dhcpd to run at boot time
Results 1 to 9 of 9

Thread: Getting madwifi, wpa_supplicant and dhcpd to run at boot time

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    84

    Getting madwifi, wpa_supplicant and dhcpd to run at boot time

    How do I get all three of these to run at boot time? I found this example script here, but I don't know how to create it or where to put it so that these commands run every time I restart my server. It's kind of a pain otherwise.

    Code:
    #!/bin/sh
    modprobe ath_pci  (If running pre-r1408 Madwifi code, then also: wlanconfig ath0 create wlandev wifi0 wlanmode sta)
    iwconfig ath0 essid "My_WPA_Protected_AP_ESSID"
    ifconfig ath0 192.168.0.100 up
    wpa_supplicant -Bw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    Thanks,
    JJJ

  2. #2
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Posts
    882
    Try putting the commands in:

    Code:
    /etc/rc.local

    My sites:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    OK, thanks. What does the ! do in this case, though?

    This is what my current rc.local file looks like:

    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    exit 0
    /usr/local/bin/noip2
    Do I have to put "exit 0" before each command?

  4. #4
    Junior Member
    Join Date
    Sep 2006
    Posts
    70

    use ntsysv

    You don't have to edit the current script. Just cut and paste your script just before exit statement. save it and test the results. An easy way, if that may work for you, is to ust ntsysv command on command line. It will help you configure services you may start automatically after your OS boots. I'll suggest you to try ntsysv command before you do any experiments with the script. This is a safer way.


    Quote Originally Posted by JoeyJoeJoe View Post
    OK, thanks. What does the ! do in this case, though?

    This is what my current rc.local file looks like:

    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    exit 0
    /usr/local/bin/noip2
    Do I have to put "exit 0" before each command?

  5. #5
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760
    I am surprised the packager didn't setup a service script for all of that. Fedora 6 and CentOS packagers did. Dunno about F7.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


  6. #6
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    ntsysv is not on my server. Can I apt-get install that?

  7. #7
    Junior Member
    Join Date
    Sep 2006
    Posts
    70
    Quote Originally Posted by JoeyJoeJoe View Post
    ntsysv is not on my server. Can I apt-get install that?
    You will find it here:
    http://rpmfind.net/linux/rpm2html/se...p?query=ntsysv

  8. #8
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    I don't see my distro listed (Ubuntu Server Feisty)

  9. #9
    Junior Member
    Join Date
    Sep 2006
    Posts
    70
    Quote Originally Posted by JoeyJoeJoe View Post
    I don't see my distro listed (Ubuntu Server Feisty)
    I am sorry, I was under an impression that you use a redhat sys. for Ubuntu you there is a different tool rcconf. Try the following:

    apt-get install rcconf

    you may also try chkconfig, the following link tells you about this tool:
    http://www.redhat.com/docs/manuals/l...chkconfig.html

Similar Threads

  1. madwifi and wpa_supplicant (UPDATED)
    By JoeyJoeJoe in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 05-16-2007, 11:26 PM
  2. madwifi and wpa_supplicant instructions vague
    By JoeyJoeJoe in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 05-15-2007, 10:23 PM
  3. Mandrake takes a long time to boot
    By in forum Linux - Software, Applications & Programming
    Replies: 29
    Last Post: 10-19-2003, 11:00 PM
  4. long time to boot linux
    By police in forum Linux - General Topics
    Replies: 8
    Last Post: 09-01-2002, 11:13 AM
  5. Application startup at boot time
    By Schotty in forum Linux - Software, Applications & Programming
    Replies: 9
    Last Post: 02-19-2002, 07:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •