Results 1 to 5 of 5

Thread: Help: VNCSever can't get library

  1. #1

    Help: VNCSever can't get library

    Hi folks;

    I am trying to get a vncserver running on my box, so far I have:
    I installed real-vncserver fine, but it asked for XAUTH, so I promptly installed that.

    It now fails telling me:
    "error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory"

    I tried installing the package from RPM finder:
    http://www.rpmfind.net/linux/rpm2htm...m=fedora&arch=

    Which seemed to work okay, but I am still getting the same errors.

    On my system uname -a does:
    Linux *** 2.6.16.53-070731a #1 SMP Tue Jul 31 10:46:54 CEST 2007 x86_64 x86_64 x86_64 GNU/Linux

  2. #2
    Fixxed now!

  3. #3

    Still problems...

    I take that back!

    Starting with a fresh fedora4 install, I double checked (find / -name *vnc*) for existing vnc but nothing, so I tried installing realvnc, and I managed to start it fine (vncserver /-start)... and yet I can't connect to it.
    I downloaded the fedora vnc from RPMS and installed that, then started that as a service (service vncserver start)- again, all the right messages, but no joy.

    The message I get when trying to connect with a client is: "unable to connect to host (connection refused 10061); " - not very helpful I know.

    I tried to run snoop on my fedora box to see if anything was happening... and guess what : snoop: command not found. Well I wasn't expecting that (as I'm logged in as root).
    I tried running netstat -a but didn't find anything helpful in there. (I'm sure I can get netstat to listen to a specific port, but can't find any advice on how).

    I know it isn't going to be easy, but can anyone offer a noob some places to start trouble shooting?

  4. #4
    I think the default port for VNC is 5900, try starting with that. It may have changed though...
    63,000 bugs in the code, 63,000 bugs,
    ya get 1 whacked with a service pack,
    now there's 63,005 bugs in the code!!

  5. #5
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760
    Fedora, Red Hat Enterprise, and CentOS have VNC in repos for them.

    In my case on FC7, its in the Fedora Core repository (included IIRC right in the install). So ... I would ensure that you install from yum/up2date to get a good package, and suck down all the needed (if any) dependencies. Then to get the stuff all going its simple:

    Start your VNC daemon and as root run vncconfig
    For the user, run vncpasswd
    then run vncserver

Similar Threads

  1. Suse 7.0 socket library
    By TaraMc in forum Suse
    Replies: 1
    Last Post: 05-15-2002, 05:00 PM
  2. WordPefect Library problems
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 05-02-2002, 09:03 PM
  3. Library help
    By in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 03-13-2002, 09:11 PM
  4. Arkhart and Mozilla JS library
    By ASCI_Blue in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 01-19-2002, 11:57 PM
  5. Library
    By Ashcrow in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 01-10-2002, 05:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •