Results 1 to 6 of 6

Thread: Forgot how to restart networking

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    84

    Forgot how to restart networking

    With redhead's help I was able to get my Ubuntu server up and running on my WPA encrypted network some time ago.

    Since then, I have shut down my server to clean up my office and now after restarting it and running wpa_supplicant and then stopping and restarting the network I still cannot get an IP address.

    It appears to be authenticating to the router as it picks up the router SSID, MAC address, etc., but whenever I ping the router I get:

    Code:
    connect: Network is unreachable
    I know this should be an easy fix. Promise to write it down this time.

    Thanks,
    JJJ

  2. #2
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    Yes, sir. That got me help with wpa_supplicant, which I know now how to startup, but I just don't know why I'm not able to ping my wireless router.

  4. #4
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    It looks like either it isn't getting a usefull IP address, or the route is messed up.

    what IP does it have, what is the gateway IP, what is the default route and whats the netmask assigned to the interface.
    Ie output of: ifconfig ath0 |grep 'inet addr:' and route -n

    Have you tried specifying to use that interface solely, ie: ping -c 4 -I ath0 130.225.96.225
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  5. #5
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    ifconfig ath0 |grep 'inet addr:'
    Nothing happens.

    route -n
    shows no destination, gateway. Nothing.

    ping -c 4 -I ath0 130.225.96.225
    No such device

  6. #6
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    Nevermind. Forgot to run dhclient on ath0.

    Once I did that, I was all set.

    I don't know how to get madwifi, wpa_supplicant and dhclient to all run automatically on boot. Is that simple enough to do?

Similar Threads

  1. [ask]Why do I cannot restart ssh in ubuntu?
    By mutala in forum Linux - General Topics
    Replies: 0
    Last Post: 09-05-2012, 02:15 PM
  2. Wireless NIC seems to require restart
    By axxis in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 01-17-2007, 06:02 AM
  3. Another poll that forgot Fatal
    By Fatal Error in forum General Chat
    Replies: 1
    Last Post: 12-28-2005, 03:39 AM
  4. forgot my password
    By nidhi in forum Linux - General Topics
    Replies: 1
    Last Post: 06-29-2004, 04:59 AM
  5. I forgot to tell everyone here
    By mcdougrs in forum General Chat
    Replies: 5
    Last Post: 09-27-2003, 01:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •