Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: CD-ROM reading

  1. #1

    CD-ROM reading

    I recently loaded SuSE Linux onto my PC. However, I can't get connected the Internet yet, so a friend has burned some downloaded files onto a CD for me. But when I put the CD in and go to Konqueror to browser through the files and hopefully open them, the browser does not reflect any files on the CD -- it just shows blank space. What's wrong? How do I fix it?


  2. #2

    Re: CD-ROM reading

    hello,
    i am guessing the CD rom is not mounted. If it does not mount auto matically open a terminal and type mount /cdrom - i think that is where suse puts its CD mount points....

  3. #3

    Re: CD-ROM reading

    have you mounted the cd-rom?

    if not run
    mount -r /dev/cdrom /mnt/cdrom

    --edit--
    great minds think alike, eh pbharris?

    mojo jojo rocks!

  4. #4
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re: CD-ROM reading

    You must mount the CD-ROM first. Bring up a terminal window, become root and type in:
    mount /dev/cdrom /cdrom
    Then you should be able to browse the /cdrom folder.

  5. #5

    Re: CD-ROM reading

    hehehehheh - looks like this linux user is covered


    Hey popcorn - i am trying to get an avator which is as ammusing as yours mojo jojo!

  6. #6

    Re: CD-ROM reading

    Thanks for everyone's replies. It appears there is some unanimity about what to do in this case. I tried to mount the cd-rom a couple times using the different syntaxes mentioned in the posts. The results that I received are the following:
    mount /dev/cdrom /cdrom
    mount: block device /dev/cdrom is write protected, mounting read-only
    mount: no medium found

    mount /cdrom
    mount: no medium found

    then I also tried accessing the control center and found the device name and tried that with the following result:
    mount /hdc
    mount: mount point /hdc does not exist


    Any further thoughts? Would the fact that the CD was burned on a Windows machine make a difference? All that we did was copy the .rpm files to the CD.


  7. #7
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re: CD-ROM reading

    Can you post the contents of your /etc/fstab file? That would help us track down the problem.

  8. #8

    Re: CD-ROM reading

    couple of things:
    when you burnt the disk did you finish the session? if not it won't be able to read it (unless mabee it's a burner you're reading it on). If you didn't you should still be able to finish the session with the software you used.

    it looks like the first thing you said actually worked but it couldn't find a file system or disk. (try with the -r arg, that'll stop the read only error)

    can you see the files if you put the disc in any other machine?


    when you do mount it remember to unmount it (umount /mnt/cdrom) when you're done. This really confused me to start with, I couldn't workout why my cdroms weren't ejecting.

  9. #9

    Re: CD-ROM reading

    does a mount -t iso9660 /dev/cdrom /cdrom get ya anything?

  10. #10
    Junior Member
    Join Date
    Dec 2001
    Location
    San Antonio
    Posts
    88

    Re: CD-ROM reading

    dgwebstuff - vi /etc/fstab and look for user option on the cdrom line. If its not there add it - options are only seperated by a comma and no spaces.


Similar Threads

  1. What are you reading?
    By halfpipe10 in forum General Chat
    Replies: 2
    Last Post: 02-11-2006, 03:33 AM
  2. Incorrect RAM Reading
    By shebang in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 10-10-2005, 06:07 AM
  3. What Book Are You Reading Right Now?
    By stryder144 in forum General Chat
    Replies: 12
    Last Post: 08-19-2005, 07:28 AM
  4. Reading variables...
    By Gary Penner in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 02-25-2005, 10:35 PM
  5. reading .html and not .php
    By pinehead in forum Linux - General Topics
    Replies: 4
    Last Post: 11-23-2002, 06:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •