Results 1 to 3 of 3

Thread: Static IP cannot Ping gateway

Hybrid View

  1. #1

    Static IP cannot Ping gateway

    My ISP uses a LAN, and a 24 Online client, apparently I can use Linc to login to the server to access the internet, but I am not able to ping the gateway. Any help will be appreciated.
    Heres the info, b.t.w I have Knoppix HD-install


    knoppix@Knoppix:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0D:87:11:82:5F
    inet addr:10.1.77.141 Bcast:10.1.77.141 Mask:255.255.255.240
    inet6 addr: fe80::20d:87ff:fe11:825f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
    RX packets:724 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:57117 (55.7 KiB) TX bytes:2134 (2.0 KiB)
    Interrupt:21

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:10 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:772 (772.0 b) TX bytes:772 (772.0 b)

    knoppix@Knoppix:~$ route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.77.128 0.0.0.0 255.255.255.240 U 0 0 0 eth0


    knoppix@Knoppix:~$ netcardconfig
    ifconfig eth0 10.1.77.141 netmask 255.255.255.240 broadcast 10.1.77.128 up
    route add default gw 10.1.77.1
    SIOCADDRT: Network is unreachable
    auto lo eth0
    Setting Nameserver in /etc/resolv.conf to 192.168.222.5
    Done.

    Following is on the same pc running windows xp with a working internet connection
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\devashish>ipconfig -all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Home-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
    rnet NIC
    Physical Address. . . . . . . . . : 00-0D-87-11-82-5F
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 10.1.77.141
    Subnet Mask . . . . . . . . . . . : 255.255.255.240
    Default Gateway . . . . . . . . . : 10.1.77.1
    DNS Servers . . . . . . . . . . . : 192.168.222.5

  2. #2

    broadcast address wrong

    I don't know the kind of setup you have with your ISP...are you using a Broadband router...Or is it a straight connection through a switch to the default gw....anyway let me see if I can help you..

    I think there is a problem with the broadcast address it's same with the IP address

    inet addr:10.1.77.141 Bcast:10.1.77.141 Mask:255.255.255.240

    For that subnet mask the Broadcast address should be 10.1.77.143....If you know subnetting.....and the default Gw should be any IP Btw 10.1.77.129-10.1.77.142......

    But according to the settings I see for windows....I assume the submask is either 255.255.255.128 0r 255.255.255.0 since you are able to reach the default gw.

    You can try the above settings by changing the in /etc/networking/interfaces.....if all else fails put the exact settings like the ones in windows using a text editor and restart networking /etc/init.d/networking force-reload....

    i hope it works.

    ChessGuru

  3. #3
    Thank you chessguru .The actual broadcast address is 10.1.77.255, i figured that by using wireshark, let me show you my windows routing table, maybe that will help!
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\devashish>route PRINT
    ================================================== =========================
    Interface List
    0x1 ........................... MS TCP Loopback interface
    0x2 ...00 0d 87 11 82 5f ...... Realtek RTL8139 Family PCI Fast Ethernet NIC - P
    acket Scheduler Miniport
    ================================================== =========================
    ================================================== =========================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric
    0.0.0.0 0.0.0.0 10.1.77.1 10.1.77.141 20
    10.1.77.128 255.255.255.240 10.1.77.141 10.1.77.141 20
    10.1.77.141 255.255.255.255 127.0.0.1 127.0.0.1 20
    10.255.255.255 255.255.255.255 10.1.77.141 10.1.77.141 20
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    224.0.0.0 240.0.0.0 10.1.77.141 10.1.77.141 20
    255.255.255.255 255.255.255.255 10.1.77.141 10.1.77.141 1
    Default Gateway: 10.1.77.1
    ================================================== =========================
    Persistent Routes:
    None

    C:\Documents and Settings\devashish>

Similar Threads

  1. setting static IP on network with no static IP address from internet provider?
    By solvetek in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 11-16-2011, 07:23 AM
  2. Setting static IP on LAN
    By myusername in forum Linux - General Topics
    Replies: 2
    Last Post: 05-07-2009, 07:24 AM
  3. Simple question about command syntax ping/log ping results
    By ohalnet in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 07-26-2006, 05:12 PM
  4. static route
    By aliko in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 05-30-2002, 01:16 PM
  5. Static and DHCP
    By Aaron_Adams in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 11-13-2001, 10:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •