Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Having Problem Installing BitchX ...
Results 1 to 6 of 6

Thread: Having Problem Installing BitchX ...

Hybrid View

  1. #1

    Having Problem Installing BitchX ...

    i do a ./configure after un-tarring the archive and get the following ..

    checking whether to use use tgetent or setupterm... setupterm
    checking for setupterm in -lncurses... no
    checking for setupterm in -lcurses... no
    checking for tgetent in -ltinfo... no
    checking for tgetent in -lmytinfo... no
    checking for setupterm in -ltinfo... no
    configure: WARNING: cannot find setupterm - trying tgetent
    checking for tgetent in -ltermlib... no
    checking for tgetent in -ltermcap... no
    checking for tgetent in -lcurses... no
    configure: error: cannot find setupterm or tgetent


    how do i fix this, i am currently using Debian 4.0

  2. #2
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935
    Do you know all you have to do is type
    Code:
    apt-get install bitchx
    at the terminal as root?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    - The truely community run Linux/Floss forum !

    No IT BS !!

  3. #3
    yeah i knew that, was just trying to figure out the error message ..

  4. #4
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935
    Quote Originally Posted by waernt View Post
    yeah i knew that, was just trying to figure out the error message ..
    Really ????????

    OK, I'm sorry that I helped you.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    - The truely community run Linux/Floss forum !

    No IT BS !!

  5. #5
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    checking for setupterm in -lncurses... no
    checking for setupterm in -lcurses... no
    You need libncurses5-dev
    checking for tgetent in -ltinfo... no
    checking for tgetent in -lmytinfo... no
    checking for setupterm in -ltinfo... no
    configure: WARNING: cannot find setupterm - trying tgetent
    you need ncurses-term
    checking for tgetent in -ltermlib... no
    checking for tgetent in -ltermcap... no
    checking for tgetent in -lcurses... no
    You need libterm-query-perl

    But the one thing you might want to ask yourself, do I have the build-essential installed... Since these kind of errors usualy comes from a poorly fitted build environment.

    Quote Originally Posted by Compunuts
    OK, I'm sorry that I helped you.
    I would go with Compunuts on this, just install the precompiled version, in todays processors theres so much power, that it isn't such a gain to specific compile for your architecture and configuration. So you lose a couple of cyckles.. But what, the processor might have a few hundreds to spare...
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  6. #6
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935
    Yeah, see, this is my main point. I've worked far and wide with all the distros and programs and all it comes down to it, it's what works.

    It's nice to have it specific to your hardware when the computing power was low. It makes sense to have it even custom kernel compiled for your CPU when you are talking about dual P 200 server and you want the most out of your computing power. But the reality is, most of us have far too many computing power than we need. So why bother compiling it when all you need is install the binary and be done with it unless of course you want to learn how something works. Then again, if it's the case, the poster should have mentioned it that he is just doing it for testing and learning. Otherwise, we will just give what's WORKS.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    - The truely community run Linux/Floss forum !

    No IT BS !!

Similar Threads

  1. BitchX Error cannot find setupterm or tgetent
    By linuxslacker in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 10-03-2009, 03:24 PM
  2. Problem to Installing Rancid2.3.2a2...
    By andang in forum Redhat / Fedora
    Replies: 1
    Last Post: 02-27-2007, 06:06 AM
  3. problem installing OSs
    By mojo jojo in forum Linux - General Topics
    Replies: 4
    Last Post: 04-04-2005, 10:17 AM
  4. Problem Installing LimeWire
    By Lixus Looser in forum Linux - General Topics
    Replies: 4
    Last Post: 01-23-2005, 03:37 PM
  5. Problem installing new Galeon 1.2
    By papanohair in forum Linux - General Topics
    Replies: 8
    Last Post: 03-19-2002, 12:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •