Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Receiving Wrong DNS IP throug DHCP
Results 1 to 4 of 4

Thread: Receiving Wrong DNS IP throug DHCP

  1. #1

    Receiving Wrong DNS IP throug DHCP

    My system when set to Static IP, the internet browsing is OK BUT When I set it to Automatic IP, the internet browsing stops.

    In my lab I have got a DSL Modem, working as dhcp and no Linux dhcp server is configured.
    When my system's IP is set to Automatic, the /etc/resolv.conf file displays "File Generated by dhcp client" and displays wrong IP for nameserver tag, instead It Displays the IP of Gateway. In DSL Modem configuration, No DNS IP have been given.

    When Static IP is given, the /etc/resolv.conf displays the Correct IP for nameserver tag as browsing works.

    NOTE: No Such Problem arise when using Windows Environment in the same lab, using Both Static as well as Automatic IPs, the internet borwing works.

    Is there any way to Receive Automatic IP only from dhcp and the not the nameserver IP
    the nameserver IP should be given and read from /etc/resolve.conf

    Please help in this matter.

    thank you.

  2. #2
    Quote Originally Posted by ITProf View Post
    My system when set to Static IP, the internet browsing is OK BUT When I set it to Automatic IP, the internet browsing stops.

    In my lab I have got a DSL Modem, working as dhcp and no Linux dhcp server is configured.
    When my system's IP is set to Automatic, the /etc/resolv.conf file displays "File Generated by dhcp client" and displays wrong IP for nameserver tag, instead It Displays the IP of Gateway. In DSL Modem configuration, No DNS IP have been given.

    When Static IP is given, the /etc/resolv.conf displays the Correct IP for nameserver tag as browsing works.

    NOTE: No Such Problem arise when using Windows Environment in the same lab, using Both Static as well as Automatic IPs, the internet borwing works.

    Is there any way to Receive Automatic IP only from dhcp and the not the nameserver IP
    the nameserver IP should be given and read from /etc/resolve.conf

    Please help in this matter.

    thank you.
    You might have a rogue DHCP server on your network. Print servers, and other network devices often have built-in DHCP that needs to be turned off. I have also seen Macs on the network do this. The fact that you are getting the the gateway IP is probably a co-incidence.

  3. #3
    Another thought. Check the DNS entry in the DSL gateway. Windows boxes have a separate setting for DNS, and would work anyway.

    The DHCP server int he gateway may be returning the wrong address.

  4. #4

    DNS client config

    You can discover from your windows boxes where they are going for name resolution.
    Add the domain of their dns server to the /etc/resolv.conf
    following 'search
    as in
    search domain.domain
    If you have an IP address for a specific name server use a nameserver statement
    as in
    nameserver 192.168.0.254
    save the file.

    If you are on a red hat machine use the gui network configuration and uncheck the obtain dns information from my dhcp server which appears when you select dhcp address assignment.

    -chrisB

Similar Threads

  1. Others not Receiving my E-Mails
    By outlook0987 in forum Windows - General Topics
    Replies: 1
    Last Post: 10-29-2006, 06:30 PM
  2. receiving e-mails
    By mick.j in forum Windows - General Topics
    Replies: 0
    Last Post: 06-30-2005, 09:19 AM
  3. Disable Wireless Router DHCP and Use Linux DHCP Server?
    By omnivore in forum Linux - General Topics
    Replies: 0
    Last Post: 01-19-2005, 04:18 PM
  4. Receiving Unrequested Email
    By in forum General Chat
    Replies: 17
    Last Post: 09-20-2003, 11:24 PM
  5. MOVED: Receiving Unrequested Email
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 09-20-2003, 02:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •