Hi all,

We have Redhat AS 4 U3 server running Squid 2.6 Stable 10. I am facing problem that our squid server stop responding after a few days. I have to restart the squid service, then the problem gets resolved.

Following things I have observed.

Everytime when squid stops responding, free memory is - 19 MB
When I restart the squid and all works fine, free memory is - around 200MB.


When squid stops responding, following are the log file entries.

cache.log -->

2007/04/13 18:06:58| WARNING: Closing client 10.8.97.26 connection due to lifetime timeout
2007/04/13 18:06:58| http://ehg-techtarget.hitbox.com/HG?...92094954737265
2007/04/13 18:06:58| WARNING: Closing client 10.184.76.249 connection due to lifetime timeout
2007/04/13 18:06:58| http://www.desktopmachine.com/
2007/04/13 18:06:58| WARNING: Closing client 10.184.59.122 connection due to lifetime timeout

2007/04/13 18:06:58| http://insider.msg.yahoo.com/yconten...&ver=8.0.0.716
2007/04/13 18:06:58| WARNING: Closing client 10.8.97.27 connection due to lifetime timeout

2007/04/13 18:06:58| http://sb.google.com/safebrowsing/up...nchash:1:22617
2007/04/13 18:06:58| WARNING: Closing client 10.8.97.26 connection due to lifetime timeout

2007/04/13 18:06:58| http://sb.google.com/safebrowsing/up...nchash:1:22617
2007/04/13 18:06:58| aioSync: flushing pending I/O operations
2007/04/13 18:06:58| aioSync: done
2007/04/13 18:06:58| Closing unlinkd pipe on FD 9
2007/04/13 18:06:58| storeDirWriteCleanLogs: Starting...
2007/04/13 18:06:58| 65536 entries written so far.
2007/04/13 18:06:58| 131072 entries written so far.
2007/04/13 18:06:58| 196608 entries written so far.
2007/04/13 18:06:58| 262144 entries written so far.
2007/04/13 18:06:58| 327680 entries written so far.
2007/04/13 18:06:58| 393216 entries written so far.
2007/04/13 18:06:58| Finished. Wrote 443956 entries.
2007/04/13 18:06:58| Took 0.3 seconds (1353710.1 entries/sec).
CPU Usage: 1870.060 seconds = 970.700 user + 899.360 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 385
Memory usage for squid via mallinfo():
total space in arena: 945172 KB
Ordinary blocks: 942155 KB 1291 blks
Small blocks: 0 KB 6 blks
Holding blocks: 7952 KB 4 blks
Free Small blocks: 0 KB
Free Ordinary blocks: 3016 KB
Total in use: 950107 KB 100%
Total free: 3016 KB 0%
2007/04/13 18:06:58| aioSync: flushing pending I/O operations
2007/04/13 18:06:58| aioSync: done
2007/04/13 18:06:58| aioSync: flushing pending I/O operations
2007/04/13 18:06:58| aioSync: done
2007/04/13 18:06:58| Squid Cache (Version 2.6.STABLE10): Exiting normally.
2007/04/13 18:07:08| Starting Squid Cache version 2.6.STABLE10 for i686-pc-linux-gnu...
2007/04/13 18:07:08| Process ID 10510
2007/04/13 18:07:08| With 32768 file descriptors available
2007/04/13 18:07:08| Using poll for the IO loop
2007/04/13 18:07:08| Performing DNS Tests...
2007/04/13 18:07:08| Successful DNS name lookup tests...
2007/04/13 18:07:08| DNS Socket created at 0.0.0.0, port 32809, FD 4
2007/04/13 18:07:08| Adding nameserver 202.138.96.47 from /etc/resolv.conf
2007/04/13 18:07:08| Adding nameserver 202.138.96.2 from /etc/resolv.conf
2007/04/13 18:07:08| User-Agent logging is disabled.
2007/04/13 18:07:08| Unlinkd pipe opened on FD 9
2007/04/13 18:07:08| Swap maxSize 16777216 KB, estimated 1290555 objects
2007/04/13 18:07:08| Target number of buckets: 64527
2007/04/13 18:07:08| Using 65536 Store buckets
2007/04/13 18:07:08| Max Mem size: 2048000 KB
2007/04/13 18:07:08| Max Swap size: 16777216 KB
2007/04/13 18:07:08| Store logging disabled
2007/04/13 18:07:08| Rebuilding storage in /cache01 (CLEAN)
2007/04/13 18:07:08| Using Least Load store dir selection
2007/04/13 18:07:08| chdir: /usr/local/squid/var/cache: (2) No such file or directory
2007/04/13 18:07:08| Current Directory is /root
2007/04/13 18:07:08| Loaded Icons.
2007/04/13 18:07:08| Accepting proxy HTTP connections at 10.8.48.89, port 8080, FD 12.
2007/04/13 18:07:08| Accepting ICP messages at 0.0.0.0, port 3130, FD 13.
2007/04/13 18:07:08| Accepting SNMP messages on port 3401, FD 14.
2007/04/13 18:07:08| WCCP Disabled.
2007/04/13 18:07:08| Configuring Parent 127.0.0.1/8081/3130
2007/04/13 18:07:08| Ready to serve requests.
2007/04/13 18:07:08| Store rebuilding is 0.9% complete


Can any body tell me what is the problem.

Thanks in advance!