Results 1 to 2 of 2

Thread: HELP - Suse 10.2 for proxy server with one ethernet

Hybrid View

  1. #1

    HELP - Suse 10.2 for proxy server with one ethernet

    Dear Suse Master..

    i have a new configuration in my network, but maybe different with another network.
    There was one router (linksys RV042) for configuration NAT, and i have different machine for only proxy server with linux suse 10.2

    1. How to start squid in linux suse 10.2...from Yast..? completly..? how to check the squid is running ?

    2. How to make squid transparent in suse 10.2 ( in many blog, squid 2.6 version we can add "transparent" behind http_port..is that right for suse too..?)

    this is my network..please help me --> "http://i7.tinypic.com/2rndlom.jpg"

    regards

  2. #2
    i don't know how much I can help you (I run squid, but not on SuSE, and I also run SuSE, but on a box that doesn't run SuSE) and I'm not even sure I've completely understood your situation, but:

    -assuming the xxx strings always mean some value in particular (that you are, very reasonably, trying to keep secret), I'm not sure what you've got can work because you've used 202.XXX.XXX.2 twice. Not good.

    -assuming the xxx strings always mean different values (that you are, very reasonably, trying to keep secret), I'm not sure what you've got can work without some cleverness in subnet masking because the router box and the DSL modem aren't on the same subnet (actually, this is easy enough to cure, but why? Why not do it the easy way?)

    Anyway, maybe I've just misunderstood what you were saying, on to your substantive question.

    - Install squid. Use yast 'install and remove software'.

    -try to configure the squid.conf file. This is actually quite a big .conf file as these things go. It usually takes me over an hour to read through line-by-line, understand each line and work out what I think is right.

    -Do not get over excited about the 'fancy-schmanzy' options that look as if they might help you increase your caching efficiency. SuSE doesn't compile them all in (most people don't and they only make small differences, but it would have been nice to have, say, the algorithm allocation, options, but, certainly a couple of years back, you didn't have them and any attempt to specify them results in an immediate crash).

    You might need a cafeine-containing drink for that stage.

    -Now try to start squid in the foreground from the command line and, preferably, as the user that squid will finally run as.

    This maybe a two drink stage. It will crash. That is expected. Work out why it has crashed, put that right and try again. Repeat until it will run. At this point, if you feel like getting fancy, try the fancy optimisations, one at a time and check they don't make it crash. For example, on any modern computer, the amounts of memory (RAM & HD) are rather small. Multiply by 2-4-6-8-16 as seems appropriate for the machine that you are using. No point in allocating more ram than the machine has, though. This will just lead to swapping and you are probably better off letting squid manage that by allocating less ram and more HD.

    -At any time you can tell whether squid is running from the command line by some incantation like
    ps -ef
    or, to cut out the junk
    ps -ef|grep -i quid
    (note; the last version should show both the ps command running and squid, if squid is running at that time; abbreviating the squid name slightly to quid should make it very clear which is the real squid command and which is only the ps -ef.)

    You can now kill the manually started squid with a 'kill process_number', where process number is visible in the ps -ef output.

    -Now use yast to specify in which run levels you want squid to be active, with the system services (is it 'services and runlevels??) module.

    Check everything starts up (ps -ef again). Have a quick look at 'top'. Done.

    By the way, the thing that you have as '10.10.0.2' - I'm not clear whether that is a switch or a router, but I'd have hung the squid box off there rather than the RV-042. In fact a few of the minor things in this layout are a bit of a mystery to me, but there may be perfectly good reasons.

Similar Threads

  1. Squid Proxy Server Question(s)
    By stryder144 in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 10-23-2010, 06:21 AM
  2. Proxy server for Linux
    By omidkamangar in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 06-11-2007, 02:18 PM
  3. ethernet card problem with suse 7.1
    By saifnawaz in forum Suse
    Replies: 1
    Last Post: 05-10-2002, 09:17 PM
  4. Setting up Proxy in SuSE 8.0
    By chadm1967 in forum Linux - General Topics
    Replies: 0
    Last Post: 05-03-2002, 03:44 PM
  5. Bypassing microsoft Proxy server
    By in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 01-24-2002, 12:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •