Results 1 to 6 of 6

Thread: Fedora Core 6 can't comm w network

  1. #1

    Fedora Core 6 can't comm w network

    I have a desktop with two hard drives. It used to have a copy of
    Windows on each drive. I decided to replace the second one with Fedora
    Core 6.

    I have never used Linux, but was a VAX/Unix user many moons ago. My
    partner is a long-time Linux user. He has figured out most of the
    problems so far, but is now stumped.

    I bought the O'Reilly "Fedora Linux" and downloaded Core 6. Below is
    what I've done so far. What should I do next?

    1. Installed per book. No boot.
    2. Made grub floppy & booted from it.
    3. Installed grub into MBR of 1st disk; now can boot either system.
    4. Tried ping; can't reach router.
    5. Rebooted Windows; ping works fine; all network ops work fine.
    6. Rebooted Fedora; still can't ping.
    7. Turned off DHCP, manually set IP; still can't ping.
    8. Turned off SELinux & Firewall; still can't ping.
    9. Patched /etc/hosts, so ping -c 1 localhost works; still cant ping.

    Here are the results of various tools:

    ping -> "Destination Host Unreachable"

    ethtool eth0 -> "No data available"

    arp -a -> "( at <incomplete> on eth0"

    ifconfig ->
    eth0 Link encap:Ethernet HWaddr 00:80:AD:7A:50F
    inet addr: Bcast: Mask:
    inet6 addr: fe80::280:adff:fe7a:50df/64 Scope:Link
    RX packets:8 errors:165 dropped:0 overruns:0 frame:0
    TX packets:46 errors:6 dropped:0 overruns:0 carrier:6
    collisions:0 txqueuelen:1000
    RX bytes:1113 (1.0 KiB) TX bytes:6858 (6.6 KiB)
    Interrupt:193 Base address:0x4c00

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1988 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1988 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4779028 (4.5 MiB) TX bytes:4779028 (4.5 MiB)

  2. #2
    Join Date
    Jan 2007
    Adelaide, Australia


    Just an idea, may or may not be of any bearing, but are you running ipv6 or ipv4 addresses on that nic? See ipv6 Wikipedia If your network card is ipv4 only, and your router ipv6, they may not be able to communicate. Hope it helps.


  3. #3
    Quote Originally Posted by mechdave View Post
    Just an idea, may or may not be of any bearing, but are you running ipv6 or ipv4 addresses on that nic? See ipv6 Wikipedia If your network card is ipv4 only, and your router ipv6, they may not be able to communicate. Hope it helps.

    I'm quite sure that's not the problem. The card works fine under Windows, and I've turned ipv6 off under Fedora.

  4. #4
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI
    What card is this?

    What are your firewall settings on the problematic machine?

    Does this machine communicate to the web? (can it resolve DNS, speak to remote POP/IMAP/SMTP/www services?)

    Using a sniffer, what does it see as eminating from that machine? Are packets actually leaving?

    These are the things I would want answered. Common issues that can cause issues would be
    -bad localhost settings (or gone as in a few cases). localhost needs to be defined and set to
    • iptables is set to filter oddly or just badly
    • selinux is misconfigured. I just diable mine since I havent had the time to learn it well enough to use correctly (note the correctly part. Alot of help out on the web is essentially fancy ways of disabling selinux, not setting the parameters to actually work)
    • bad module configuration. Builtin kernel drivers are fine generally, but when it comes to third party drivers, a misconfiguration can be hellish on ones nerves. Ensure that if there is a third party module being used, it is setup correctly

    Hope this helps a bit. Post what you can. Perhaps there is a known issue with your NIC or the firmware.

  5. #5
    Try something like
    route add default gw 192.168.x.x
    where 192.168.x.x = your gateway.
    My crime is that of curiosity. My crime is that of judging people by what they say and think, not what they look like. My crime is that of outsmarting you, something that you will never forgive.

  6. #6

    The link below saved my bacon and may help you save yours...

    To quote from the page:

    "A bug in anaconda and another in system-config-network can lead to a broken /etc/hosts file. This results in various networking services not starting or otherwise misbehaving."

    I followed the simplistic instructions provided and voila! - a fedora box communicating with the rest of my network...

    However, I'd hate to tell you how many hours I spent searching the web and fooling around with other alleged solutions. This one worked for me and I am frankly quite surprised this issue is not documented more prevalently on some of the more popular linux and fedora sites.

    Hope it helps.

Similar Threads

  1. Fedora Core 10
    By kupertini in forum Redhat / Fedora
    Replies: 1
    Last Post: 10-16-2008, 01:30 AM
  2. Fedora Core 5-T1 DVD
    By GhostDawg in forum Linux - General Topics
    Replies: 2
    Last Post: 11-29-2005, 02:31 PM
  3. Fedora Core 4 Available
    By trickster in forum General Chat
    Replies: 14
    Last Post: 09-27-2005, 05:24 AM
  4. Fedora Core 2
    By in forum Linux - General Topics
    Replies: 49
    Last Post: 06-12-2004, 11:57 AM
  5. Fedora Core 2 is here
    By babbing in forum Redhat / Fedora
    Replies: 3
    Last Post: 05-31-2004, 06:05 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts