Hmm I think my last post was rather messy, but I'll try to explain better.

When I unpacked the SDL 1.2.4 and the I ran ./configure, make, make install
and it ran, after that I unpacked the SDL_Mixer1.2.4 and ran ./configure,
this is where it says that SDL 1.2.4 is not correctly installed or it has been moved or installied incorrectly
installed. any ideas?