Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Newbie questions about dual-booting FC6 and XP
Results 1 to 7 of 7

Thread: Newbie questions about dual-booting FC6 and XP

Hybrid View

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    84

    Newbie questions about dual-booting FC6 and XP

    I need newbie direction in order to dual boot FC6 with XP.

    My configuration is two 40GB HDD. Disk 0 has XP on it and Disk 1 has Fedora Core installed. No matter what, though, my computer continues to boot into XP. I never get prompted by GRUB to pick an operating system.

    I know my way around disk management in XP but I'm totally green in the UNIX/Linux world so be kind

  2. #2
    My guess is that you installed Windows after FC6, and Windows overwrote the MBR.

    Take a look at the following links:

    http://linuxhelp.blogspot.com/2005/1...-and-boot.html
    http://www.ozzu.com/ftopic47272.html
    http://www.fedoraforum.org/forum/arc...php/t-235.html
    My crime is that of curiosity. My crime is that of judging people by what they say and think, not what they look like. My crime is that of outsmarting you, something that you will never forgive.

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    Not so. I had already installed XP on disk 0 before trying to install FC6 on disk 1.

    I just completed a reinstall (my seventh or eighth, but who's counting ) where I indicated GRUB to use FC6 as the default OS and it still boots to XP.

    I'll look at those links.

  4. #4
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    I tried running grub-install /dev/hda and I got the error:

    "More than one install devices?"

    and it dropped back into the shell

  5. #5
    Please note how one of the links I indicated mentions that /boot needs to be installed on the first hard drive. You might want to re-read that.

    Otherwise, look at this:

    Option 1: http://www.linuxquestions.org/questi...d.php?t=495743

    Option 2: http://www.fedoraforum.org/forum/sho...d.php?t=121495

    http://www.linuxforums.org/forum/ins...-possible.html
    My crime is that of curiosity. My crime is that of judging people by what they say and think, not what they look like. My crime is that of outsmarting you, something that you will never forgive.

  6. #6
    I think you need to install your boot partition on your disk 0 or on the master drive
    Registered Linux User # 279330

  7. #7
    Junior Member
    Join Date
    Nov 2006
    Posts
    84
    Progress, but some setbacks...

    I finally got GRUB to present both OS to choose from by running 'linux rescue', mounting my image and then running 'grub-install' per these instructions with the caveat that I was installing on hda (not sda). I rebooted and chose to load XP. Worked like a champ.

    Then I rebooted XP, got the Dell BIOS screen and GRUB started to load. Then the BIOS screen. Then GRUB again. Then BIOS. GRUB was in an infinite loop. I booted to my XP system disk and went into recovery console where I ran fixmbr. Rebooted the system and no GRUB (as expected). XP came up shortly thereafter without issue.

    So, I booted to my FC6 DVD and did the 'linux rescue' thing again, reinstalling GRUB once more on hda. Installed, no problem.

    This is the contents of the device map \boot\grub\device.map. Check to see if this is correct or not...."

    (fd0) /dev/fd0
    (hd0) /dev/hda
    (hd1) /dev/hdb
    (hd2) /dev/sda
    Map looked ok to me. Floppy, two physical HDD and one external IEEE 1394 drive. No problems. Reboot and GRUB comes up asking me to choose OS, so this time I chose my FC6 install and go through the intial setup of FC6, fiddle around for a while and shutdown the computer.

    Reboot and we're back to the GRUB loop again.

    What's going on? I can't fixmbr every time I want to boot into Linux

Similar Threads

  1. Dual booting W2K and Linux
    By peter in forum Tutorials
    Replies: 0
    Last Post: 11-24-2008, 02:58 AM
  2. Dual booting with GRUB
    By chumley in forum Linux - General Topics
    Replies: 20
    Last Post: 07-14-2005, 09:16 PM
  3. dual booting
    By pinehead in forum Linux - General Topics
    Replies: 4
    Last Post: 05-30-2004, 02:44 PM
  4. Dual booting
    By Lunke in forum Linux - General Topics
    Replies: 7
    Last Post: 09-02-2003, 10:03 PM
  5. Dual booting, Linux/XP and cd glitch
    By mikeee in forum Linux - General Topics
    Replies: 6
    Last Post: 05-27-2002, 01:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •