Hello!
I have Mandriva2006 installed in my laptop Toshiba S1800-100.
I have tried to install the usb card wireless D-Link DWL-G122 B1.
While installing the driver for the card the command modprobe rt2570 did not work, so I changed the Makefile from usr/src/linux : in the line EXTRAVERSION = -12mdkcustom I put EXTRAVERSION = -12mdk.

Now when I start the system with the wireless card inside the usb port, the computer freezes. If I put the card into the usb port after starting the system, the card is recognized, but the keyboard freezes in about three minutes; the mouse works; the other usb port does not, when I tried to put there the memory stick it was not recognized.

Here is the message from the syslog file that I think corresponds to the moment of hanging up:

Sep 30 13:49:23 localhost kernel: hub 1-0:1.0: port 2 disabled by hub (EMI?), re-enabling...
Sep 30 13:49:23 localhost kernel: usb 1-2: USB disconnect, address 2

The memory stick alone works perfectly, without any problem.

I hope somebody can help me.
Thank you all in advance.
Irina