Results 1 to 2 of 2

Thread: XP nogo with Linux DNS

  1. #1
    Associate
    Join Date
    Jan 2005
    Location
    SLC, UT, USA
    Posts
    11

    XP nogo with Linux DNS

    FC3 as dns server, fully patched running bind-chroot 9.2.5.

    When configure an XP SP2 box (with or without FW running) to use the FC3 as DNS, can't resolve anything, gets error:


    "DNS request timed out.
    timeout was 2 seconds.
    *** Can't find server name for address 10.11.0.3: Timed out
    *** Default servers are not available
    Server: UnKnown
    Address: 10.11.0.3

    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    *** Request to UnKnown timed-out"


    If XP is set to use ISP DNS, works no problem.


    Named.conf uses internal and external "view" sections with different sets of zone files, depending on whether dns queries come from internal nat'd or external nets.

    Host/ping commands on server works for any hosts in zone files, and any external domains/ip's. All resolution is via named, not /etc/hosts.

    Iptables blocks all except 21,53,80,443.

    Ps shows "/usr/sbin/named -u named -t /var/named/chroot".

    /var/log/messages shows named start and load all the zone files with no errors.

    Netstat -an shows 127.0.0.1 and 10.11.0.3 listening on port 53.

    Nmap scan of the FC3 dns server from the XP box shows port 53 open.

    I imagine it's got to be something obvious in my named.conf file, but I can't figure out what it is. Here is the file:



    //
    // named.conf for Red Hat caching-nameserver
    //

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };


    view "internal" {
    match-clients { localnets; localhost; };

    zone "." IN {
    type hint;
    file "named.ca";
    };

    zone "localdomain" IN {
    type master;
    file "localdomain.zone";
    allow-update { none; };
    };

    zone "localhost" IN {
    type master;
    file "localhost.zone";
    allow-update { none; };
    };

    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "named.local";
    allow-update { none; };
    };

    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 .0.0.0.0.0.0.ip6.arpa" IN {
    type master;
    file "named.ip6.local";
    allow-update { none; };
    };

    zone "255.in-addr.arpa" IN {
    type master;
    file "named.broadcast";
    allow-update { none; };
    };

    zone "0.in-addr.arpa" IN {
    type master;
    file "named.zero";
    allow-update { none; };
    };

    zone "0.11.10.in-addr.arpa" IN {
    type master;
    file "10.11.0.zone";
    allow-update { none; };
    };

    zone "domain.net" {
    type master;
    notify no;
    file "domain.home.zone";
    allow-query { any; };
    };
    };

    view "external" {
    match-clients { any; };
    recursion no;

    zone "domain.net" {
    type master;
    notify no;
    allow-query { any; };
    file "domain.zone";
    };

    zone "0.11.10.in-addr.arpa" {
    type master;
    notify no;
    file "10.11.0.zone";
    };
    };

    logging {
    category lame-servers { null; };
    };

    include "/etc/rndc.key";

  2. #2
    Does bind give any errors in /var/log/messages when it is restarted?

    On the DNS server, does the host command work when specifically directed to a NIC interface of the DNS server? If it doesn't you may have a server configuration problem, not the client.

    Code:
    # host www.cnn.com dns-server-ip-address

Similar Threads

  1. 'view' option in named.conf is nogo
    By paleogryph in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 09-06-2005, 09:56 PM
  2. Red Hat 9, Keyboard NoGo
    By vwgtiturbo in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 04-23-2003, 03:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •