While dealing with Suse 10.1 (which I now have decided that I HATE more than anything) I noticed that the new Zen updater and YAST aren't jiving, as far as installation sources. One has sources that aren't listed in the other. Check out the link:

http://www.rondeagle.com/random/Updater.jpg

Also, I found that I can't add a local directory as an installation source! It just says that it can't add the directory, do I want to try again. How on earth... I guess I can use RPM and source to install packages, but that might get REALLY messy after a while.

Between this unfamiliar hell, and my issues with libraries not linking, I think it may be time to reinstall 10.0...