Results 1 to 2 of 2

Thread: xawtv limping along

  1. #1

    xawtv limping along

    I want to run xawtv. I get the video in black and white and no sound.
    I want color and sound.

    I get these warnings when running v4l-conf & xawtv:

    v4l-conf -a 0xD0000000
    v4l-conf: using X11 display :0.0
    WARNING: Your X-Server has no DGA support. <<<----
    using user provided base address 0xd0000000
    mode: 640x480, depth=8, bpp=8, bpl=640, base=0xd0000000
    /dev/video0 [v4l2]: configuration done

    xawtv -c /dev/video0
    This is xawtv-/opt/Xawtv, running on Linux/i686 (
    Warning: Cannot allocate colormap entry for "lightgray" <<<----
    switching visual (0x32)
    xinerama 0: 640x480+0+0
    WARNING: Your X-Server has no DGA support. <<<----
    Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct <<<----

    I added 'Load "v4l" and Load "dga" ' in xorg.conf
    Can someone explain the meaning of the warnings and how to correct them ?

  2. #2
    I worked out the color problem by using a script which runs v4l before executing xawtv and then adds '-c /dev/video0' to the xawtv command. Also added the DGA via the xorg.conf file.
    Still no audio (ran alsaconf to be sure) even tho audio tests OK when I run a .wav/.au file. The setup works on XP but the video isn't as good. Still needing audio help.

Similar Threads

  1. xawtv
    By kawipoo in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 04-21-2003, 01:24 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts