Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
DVDs not playing in mplayer
Results 1 to 10 of 11

Thread: DVDs not playing in mplayer

Hybrid View

  1. #1

    DVDs not playing in mplayer

    Hey, I dunno why but my dvds arent playing in mplayer (got the codecs installed) and Ihave libdvdcss installed also, totem wont even play it.

  2. #2
    If you run mplayer from a shell, do you see any error output?
    My crime is that of curiosity. My crime is that of judging people by what they say and think, not what they look like. My crime is that of outsmarting you, something that you will never forgive.

  3. #3
    Mentor jro's Avatar
    Join Date
    May 2004
    Location
    Pennsylvania, USA
    Posts
    1,206
    It might depend on the DVD too, some use encryption that none of the Linux codecs can play. I have noticed that with some of the newer more popular movies. This isn't always, just some of the time.
    jro -
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Linux counter#:213782
    GnuPG ID: 406238E7

  4. #4
    Moderator
    Advisor
    redhead's Avatar
    Join Date
    Jun 2001
    Location
    Copenhagen, Denmark
    Posts
    811
    I've had problems with getting mplayer to play dvds, not because the codec is nonexiting or anythign like that, but I never figured out how to overcome it, so now I mostly use xine for playing dvds.
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

  5. #5
    Same deal for me. Never did figure out that mplayer deal. I've always used Totem with the xine backend for playing DVDs and it's worked like a dream. Search yum for totem and see if you can find anything with the xine backend. If not, maybe totem-gstreamer is finally up to the task? It's been "getting there" for about 2 years now.
    I lost my self-respect at Wes' Rib House

  6. #6
    hmmm just a thought ... maybe the dvd media itself do have problems... will the disk works with dvd players?
    Registered Linux User # 279330

  7. #7
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760
    My thinking is this -- what is the error? If you open the dvd off the cli in the apps that dont work (like mplayer here), what is the error that causes the app to not play the dvd?

    My bet is it is looking at one spot for the codecs, but you have them elsewhere. As aforementioned, Totem is a bit easier since you can add codecs very easily thru Totem's preferences. Mplayer always told me where to put them (forget offhand). And I just put them there and it worked.

    Now IIRC, there is a config file that can tell mplayer a specific loc, such as the $HOME/.mplayerrc/codecs/. Perhaps you can verify that?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Similar Threads

  1. Backing up to DVDs.
    By t048 in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 02-02-2005, 12:02 PM
  2. Playing asf stream in mplayer
    By cloverm in forum Linux - General Topics
    Replies: 2
    Last Post: 12-24-2004, 03:50 AM
  3. new dvds
    By in forum General Chat
    Replies: 24
    Last Post: 07-13-2004, 09:24 PM
  4. DAT file is not playing bye Xine or Mplayer.
    By in forum Linux - General Topics
    Replies: 0
    Last Post: 11-10-2003, 06:37 PM
  5. playing video and playing mp3
    By rowy in forum Linux - Software, Applications & Programming
    Replies: 13
    Last Post: 03-15-2003, 09:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •