Results 1 to 3 of 3

Thread: Lost my logins!

  1. #1

    Question Lost my logins!

    Hi--

    Hope you can help me.

    Recently I ran apt-get upgrade on my Red Hat 9.0 machine. It said it upgraded the kernel among other things.

    Not sure if I rebooted when I did the upgrade, but I did tonight and now I cannot ssh into the machine, nor can I login from the console. ssh reports:
    Code:
    ssh_exchange_identification: Connection closed by remote host
    and the terminal asks for a password and when I enter it and hit <ret> it simply gives me a new login prompt.

    Other computers can still login to this as a samba server.

    What do you suppose I did, and how can I troubleshoot how to fix it?

    Thanks!

    OK, here are some clues:

    When I try to login from the console and give it the proper password, it immediately gives me another login prompt. But when I give it a wrong password, it pauses 2 or 3 seconds and then gives me an incorrect password message. So it seems it knows when there is a good password, it just does not know how to give me a command prompt.

    I cannot seem to get anywhere with a rescue disk.

    I can login to webmin.

    On webmin, /var/log/secure reports on the last 20 lines:
    Code:
    Mar  5 20:04:56 samba1 login: Authentication service cannot retrieve authentication info.
    Mar  5 20:14:36 samba1 sshd[3867]: refused connect from doug2 (192.168.0.107)
    Mar  5 20:23:39 samba1 sshd[3612]: Received signal 15; terminating.
    Mar  5 20:25:06 samba1 sshd[3610]: Server listening on 0.0.0.0 port 22.
    Mar  5 20:25:17 samba1 webmin[3839]: Webmin starting 
    Mar  5 20:25:28 samba1 login: pam_ldap: ldap_simple_bind Can't contact LDAP server
    Mar  5 20:25:28 samba1 login: Authentication service cannot retrieve authentication info.
    Mar  5 20:28:06 samba1 sshd[3610]: Received signal 15; terminating.
    Mar  5 20:55:54 samba1 sshd[3613]: Server listening on 0.0.0.0 port 22.
    Mar  5 20:56:06 samba1 webmin[3842]: Webmin starting 
    Mar  5 20:56:20 samba1 login: pam_ldap: ldap_simple_bind Can't contact LDAP server
    Mar  5 20:56:20 samba1 login: Authentication service cannot retrieve authentication info.
    Mar  5 20:58:24 samba1 webmin[3860]: Successful login as admin from 192.168.0.107 
    Mar  5 20:59:17 samba1 sshd[3887]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
    Mar  5 20:59:17 samba1 sshd[3887]: fatal: Cannot bind any address.
    Mar  5 20:59:27 samba1 sshd[3894]: refused connect from doug2 (192.168.0.107)
    Mar  5 21:05:01 samba1 sshd[3969]: refused connect from samba1 (192.168.0.200)
    Mar  5 21:05:05 samba1 sshd[3971]: refused connect from doug2 (192.168.0.107)
    Mar  5 21:21:05 samba1 webmin[4094]: Logout by admin from 192.168.0.107 
    Mar  5 21:23:52 samba1 webmin[4096]: Successful login as admin from 192.168.0.107
    Today I was trying to clean up some attempts to make nis and ldap work. So I deleted or changed or shut off things like ypserv, yppasswdd, ypbind, ypxfrd, and /etc/hosts.deny and hosts.allow.

    Do these give us any directions to go?

    Thanks!

  2. #2
    Can you use the rescue disk to reverse the changes you did, particularly to hosts.allo and hosts.deny?
    My crime is that of curiosity. My crime is that of judging people by what they say and think, not what they look like. My crime is that of outsmarting you, something that you will never forgive.

  3. #3

    Question

    trickster--

    I can make any change I need in those files, and even rename them through webmin and through mounts from other machines. But that does not seem to be the problem.

    I have gone back and reinstalled the ypserv stuff, and that does not give it back to me.

    I did rename both those files and nothing changed. Here is the log from /var/log/secure:
    Code:
    Mar  6 23:13:03 samba1 sshd[9310]: pam_ldap: ldap_simple_bind Can't contact LDAP server
    Mar  6 23:13:03 samba1 sshd[9310]: PAM rejected by account configuration[9]: Authentication service cannot retrieve authentication info.
    Mar  6 23:13:03 samba1 sshd[9310]: Failed password for doug from 192.168.0.107 port 43979 ssh2
    Mar  6 23:13:03 samba1 sshd[9310]: fatal: monitor_read: unsupported request: 24
    Mar  6 23:17:04 samba1 login: pam_ldap: ldap_simple_bind Can't contact LDAP server
    Mar  6 23:17:04 samba1 login: Authentication service cannot retrieve authentication info.
    The 23:13 entries are a login attempt from ssh; the 23:17 are from the console itself. Looks to me like it is expecting pam_ldap. Any ideas what that might be pointing to? Perhaps I disabled something there....

    Thanks for the ideas, and the very quick response. Hope you have some other ideas!

Similar Threads

  1. Wiki / PETs Logins
    By peter in forum Linux - General Topics
    Replies: 17
    Last Post: 03-05-2006, 08:00 PM
  2. Frontpage Logins...
    By mcangeli in forum General Chat
    Replies: 2
    Last Post: 06-30-2005, 12:17 PM
  3. Novell Grace Logins
    By countach44 in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 05-11-2005, 09:16 PM
  4. Passwordless logins
    By Schotty in forum Linux - General Topics
    Replies: 2
    Last Post: 10-15-2003, 05:48 PM
  5. Restrict root logins
    By Blaqb0x in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 04-07-2003, 08:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •