Hello !

I am working on VS-ftpd.By default i had the following /etc/pam.d/vsftpd file:

#%PAM-1.0
auth required pam_listfile.so item=user sense=deny file=/etc/vsftpd.ftpusers onerr=succeed
auth required pam_stack.so service=system-auth
auth required pam_shells.so
account required pam_stack.so service=system-auth
session required pam_stack.so service=system-auth

Now, to create virtual users in vsftdp i changed the file to :

auth required pam_pwdfile.so pwdfile /etc/vsftpd/passwd
account required pam_permit.so

The virtual users can now login but local users cannot login successfully.If i reset back to the previous settings only local users will be allowed to login and virtual users will be denied.

Is there any way to allow both type of users at the same time?