Results 1 to 4 of 4

Thread: NFS & NIS: permission denied

  1. #1

    Question NFS & NIS: permission denied


    Hope you can help me--I've got a good 25-30 hours in on this so far and feel like I am getting close, but still going in circles.

    The network I am setting up will be about 4 desktop users and a server. The server is Red Hat 9.0 and the desktops are Ubuntu 5.10.

    I am able to mount an nfs drive, but when I do an ls -alh, all the directories beyond the directory mounted say "Permission denied." (In other words, the mountpoint is /sam and the directoy mounted is vol22. I can list all the files and directories at /sam/vol22 (and even open some files there), but if I do ls -alh /sam/vol22/data, all its directories and files are "permission denied.")

    Here is how far I have gotten after this saga:
    root@doug2:/home/doug # rpcinfo -p
       program vers proto   port
        100000    2   tcp    111  portmapper
        100000    2   udp    111  portmapper
        100024    1   udp    858  status
        100024    1   tcp    861  status
        100007    2   udp    869  ypbind
        100007    1   udp    869  ypbind
        100007    2   tcp    872  ypbind
        100007    1   tcp    872  ypbind
        100021    1   udp  32874  nlockmgr
        100021    3   udp  32874  nlockmgr
        100021    4   udp  32874  nlockmgr
        100021    1   tcp  32776  nlockmgr
        100021    3   tcp  32776  nlockmgr
        100021    4   tcp  32776  nlockmgr
    root@doug2:/home/doug #
    root@doug2:/home/doug # rpcinfo -p samba1
       program vers proto   port
        100000    2   tcp    111  portmapper
        100000    2   udp    111  portmapper
        100024    1   udp  32768  status
        100024    1   tcp  32768  status
        391002    2   tcp  32769  sgi_fam
        100009    1   udp    742  yppasswdd
        100011    1   udp    929  rquotad
        100011    2   udp    929  rquotad
        100011    1   tcp    932  rquotad
        100011    2   tcp    932  rquotad
        100003    2   udp   2049  nfs
        100003    3   udp   2049  nfs
        100021    1   udp  33223  nlockmgr
        100021    3   udp  33223  nlockmgr
        100021    4   udp  33223  nlockmgr
        100005    1   udp  33224  mountd
        100005    1   tcp  32959  mountd
        100005    2   udp  33224  mountd
        100005    2   tcp  32959  mountd
        100005    3   udp  33224  mountd
        100005    3   tcp  32959  mountd
        100004    2   udp    765  ypserv
        100004    1   udp    765  ypserv
        100004    2   tcp    768  ypserv
        100004    1   tcp    768  ypserv
        100007    2   udp    995  ypbind
        100007    1   udp    995  ypbind
        100007    2   tcp    998  ypbind
        100007    1   tcp    998  ypbind
     600100069    1   udp   1020  fypxfrd
     600100069    1   tcp   1022  fypxfrd
    root@doug2:/home/doug #
    samba1 is the server, doug2 is the client.

    The /etc/fstab for this directory is:

    samba1:/vol22   /sam/vol22      nfs     rw,hard,intr              0       0
    On doug2, id returns a uid=1000(doug) (among other things, and on samba1, it returns uid=500(doug). I thought NIS made them see it as the same uid....

    So, what suggestions do you have to help me? Thanks, many, many thanks!

  2. #2
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    What if you mount with the mount option "user" in addition to rw,hard,intr ? Just a guess though since I don't use NFS.
    LinuxVillage - The truely community run Linux/Floss forum !

    No IT BS !!

  3. #3
    Mentor jro's Avatar
    Join Date
    May 2004
    Pennsylvania, USA
    Hello dgermann, this probably isn't the answer you are looking for, but I recommend going with Samba to share files between your clients. For one, if you introduce a Windows machine into the network, they can see your shares. But the paramount issue that made me dump NFS forever, or at least until they fix it, is that NFS clients do not handle an NFS server crash gracefully. I worked for a year to make the clients not hang when the server crashed, but I finally gave up and did file sharing via Samba, no problems to date.
    jro -
    Linux counter#:213782
    GnuPG ID: 406238E7

  4. #4



    Thanks for the quick reply.

    I tried this and it made no difference. Other ideas?


    Hmmm.... From another person I got the provacative idea that using Samba for allowing linux boxes to communicate was like translating a message from English to Chinese and then back to English at the other end. So I wanted to do it the "straight through" way.

    The difficulty with samba for me is that the file permissions are not the same as what actually exists on the server. For instance, my samba mounts in fstab are for a fmask and dmask both of 775. So while the file on the server may be 664, to samba it looks like 775.

    Samba is working fine currently--I have used the server for serving up shares to several Win95 boxes for the last 2 1/2 years.

    But I worry about these things.

    As to the ungraceful lockups of NFS, I ran across something in one HOWTO or another--I think it had to do with allowing immediate writes, perhaps it was called sync. I could be wrong, but if that would help solve the difficulty you had, perhaps it would be worth looking into. OTOH, if sync-ing does not solve your problem, then it gives me pause for trying this NFS stuff.

    The problem I'm having with samba permissions is that some things in OOo, like templates and autotext do not work right for me, and it sure seems like it is a rights/permissions issue.

    Thanks for your help, jro, and I hope you can shed some more light on this for me.


Similar Threads

  1. /var/spool/squid: (13) Permission denied
    By c4rdinal in forum Redhat / Fedora
    Replies: 1
    Last Post: 01-08-2007, 12:11 PM
  2. Access denied
    By daypack in forum Windows - General Topics
    Replies: 1
    Last Post: 10-27-2006, 09:04 PM
  3. chown <ldap user> <dir>, permission denied
    By djekels in forum Linux - General Topics
    Replies: 1
    Last Post: 03-15-2006, 11:30 PM
  4. permission denied
    By rwtoften in forum Linux - General Topics
    Replies: 4
    Last Post: 06-10-2002, 02:57 AM
  5. permission denied, wtf?
    By boblucci in forum Linux - General Topics
    Replies: 20
    Last Post: 11-30-2001, 12:19 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts