Results 1 to 6 of 6

Thread: PHLAK

  1. #1

    PHLAK

    So I installed PHLAK (the Professional Hacker's Linux Assault Kit) to my hard drive. When I was running it from CD, everything ran without a hitch. When I installed it to my hard drive, networking stopped working. Someone help me out here. If anyone can help, email me at irishsquid@gmail.com

    or IM on AIM: seagoingirishman
    on Yahoo player589
    on MSN theseafaringleprechaun@hotmail.com
    on ICQ 49017455

    thanks.

  2. #2

    Re:PHLAK

    hello,
    what does ifconfig return?

  3. #3

    Re:PHLAK

    ifconfig with no parameters returns nothing...device not recognized or some such nonsense...which seems to suggest that I do not have an active ethernet device...

    If I run ifconfig eth0, it returns showing the number of packets received and transmitted...if I run the command again after a few minutes, it shows a different number...so I'm assuming my NIC card is still transmitting and receiving...

    I am not, by any means, a Linux guru...so I'm pretty sure I'm just missing something insignificant...

    I just can't understand why it would work when running from the CD, but when installed to the hard drive, it doesn't work anymore...

  4. #4

    Re:PHLAK

    Hi,

    If I run
    Code:
    /sbin/ifconfig eth0
    I get the following output:

    Code:
    vmware@vmware-bavm:~$ /sbin/ifconfig eth0
    eth0      Link encap:Ethernet  HWaddr 00:0C:29:C7:D5:8C
              inet addr:192.168.6.128  Bcast:192.168.6.255  Mask:255.255.255.0
              inet6 addr: fe80::20c:29ff:fec7:d58c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:71 errors:0 dropped:0 overruns:0 frame:0
              TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:44070 (43.0 KiB)  TX bytes:6878 (6.7 KiB)
              Interrupt:18 Base address:0x1400
    As you can see, the inet addr: part shows my ip address as being 192.168.6.128.

    If you run that command, do you get an "inet addr" on that field?

  5. #5

    Re:PHLAK

    I get no ip address when I run ifconfig...

    I attempted to "arp -s (network address) (physical address)"

    but I got "network unreachable"

    I then noticed that my physical address under the ifconfig does not match my actual hardware address.

    When I run from the CD, it runs eth1 instead of eth0, and has the proper IP, Broadcast, Subnet, and default gateway, and also the proper hardware address.

    What "magic button" sort of command should I use to fix this?!

  6. #6

    Re:PHLAK

    Do you happen to have more than one network adapter installed on your pc?

    try to force your nic to get an ip address:

    Code:
    /sbin/dhclient eth0
    or
    Code:
    /sbin/dhclient eth1
    If that doesn't work, I'm thinking perhaps that your network card driver might not be loading at boottime.

    Can you post the result of the comand
    Code:
    lsmod
    ?
    This should show what drivers are loaded.

Similar Threads

  1. Back in PHLAK
    By countach44 in forum Linux - General Topics
    Replies: 1
    Last Post: 05-12-2004, 02:01 AM
  2. PHLAK
    By 10Dedfish in forum Linux - General Topics
    Replies: 6
    Last Post: 02-21-2004, 04:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •