Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Slack 10 Kernel 2.6.9 Recompile - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Slack 10 Kernel 2.6.9 Recompile

  1. #11

    Re: Slack 10 Kernel 2.6.9 Recompile

    A lot of them also refer to improper characters, such as spaces, used in the EXTRAVERSION. Be careful there. You might also consider getting rid of the directory(s) that modules_install is using, since it seems like you have done this a few times.

    Another tip: When you edit the EXTRAVERSION, make sure to start over at the make dep stage, since everything forward of that is dependent upon it.

  2. #12

    Re: Slack 10 Kernel 2.6.9 Recompile

    What I ended up doing the last time is leaving it to it's default values (I believe it is '-1' or something like that...). I got rid of the modules_install directory (linux-2.6.9) starting at about the 4th time or so. As far as the 'make dep', isn't that obsolete with the 2.6 kernels? I get a warning every time I do it, and it says something about not being necessary anymore... Beats me. I don't know what the good points of the 2.6 kernel, but my system will not be using it for now. I will get it figured out eventually, but I think it is going to take alot of time. Everything that I have found online (which isn't much, really) talks about things (potential solutions) that we have already discussed here. I did all of them, with no luck. Crap.
    Asus A8V Deluxe Mobo
    AMD Athlon64 X2 4400 -939
    2GB Crucial DDR3200 Dual-Channel
    ATi AiW 9800 Pro 128DDR
    Audigy2 ZS
    Sony DRU-810 DVD+RW DL
    3 x Maxtor MaxLine SATA 160Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 300Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 120Gb 16Mb Cache

  3. #13

    Re: Slack 10 Kernel 2.6.9 Recompile

    I'm guessing here, but from these error messages what I think is happening is that make modules_install is trying to find a directory, and if not found create it and put the modules in it. So perhaps the problem lies in you don't have access rights to the area in which this directory is being created.

    My question. Are you root when you execute this command? Also you may wish to scrap your downloaded kernel, and re-download a new one. Perhaps the one you have is corrupted somehow.
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  4. #14

    Re: Slack 10 Kernel 2.6.9 Recompile

    Yeah, I ended up doing the entire procedure as root, instead of just switching to root at modules_install. Is there some sort of script that the system follows when you execute 'make modules_install'? If it is script based, maybe I could look at it and see what the heck is going on...
    Asus A8V Deluxe Mobo
    AMD Athlon64 X2 4400 -939
    2GB Crucial DDR3200 Dual-Channel
    ATi AiW 9800 Pro 128DDR
    Audigy2 ZS
    Sony DRU-810 DVD+RW DL
    3 x Maxtor MaxLine SATA 160Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 300Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 120Gb 16Mb Cache

  5. #15

    Re: Slack 10 Kernel 2.6.9 Recompile

    Quote Originally Posted by vwgtiturbo
    I get this error:

    root@hell:/usr/src/linux-2.6.9# make modules_install
    ln: when making multiple links, last argument must be a directory
    make: *** [_modinst_] Error 1
    I had this same problem.. after plenty of messing around, I finally discovered that there was whitespace after my EXTRAVERSION:

    ie.
    "EXTRAVERSION = -win4lin "
    vs.
    "EXTRAVERSION = -win4lin"

    this fixed it right up..

    hope this helps,

    Brice Burgess

  6. #16

    Re: Slack 10 Kernel 2.6.9 Recompile

    Thanks for the tip! I have been searching for DAYS for an answer to this. I really hope that this is my problem...
    Asus A8V Deluxe Mobo
    AMD Athlon64 X2 4400 -939
    2GB Crucial DDR3200 Dual-Channel
    ATi AiW 9800 Pro 128DDR
    Audigy2 ZS
    Sony DRU-810 DVD+RW DL
    3 x Maxtor MaxLine SATA 160Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 300Gb 16Mb Cache
    1 x Maxtor MaxLine SATA 120Gb 16Mb Cache

  7. #17
    Newbie
    Join Date
    Jun 2005
    Posts
    1

    Re: Slack 10 Kernel 2.6.9 Recompile

    That did it for me! Thanks. I had a little space when I changed the Extraversion... doh!!!

    Quote Originally Posted by brice
    Quote Originally Posted by vwgtiturbo
    I get this error:

    root@hell:/usr/src/linux-2.6.9# make modules_install
    ln: when making multiple links, last argument must be a directory
    make: *** [_modinst_] Error 1
    I had this same problem.. after plenty of messing around, I finally discovered that there was whitespace after my EXTRAVERSION:

    ie.
    "EXTRAVERSION = -win4lin "
    vs.
    "EXTRAVERSION = -win4lin"

    this fixed it right up..

    hope this helps,

    Brice Burgess

Similar Threads

  1. 10 steps to recompile kernel
    By Tamil in forum Linux - General Topics
    Replies: 0
    Last Post: 11-04-2006, 09:16 PM
  2. DHCP not working after kernel recompile
    By imported_RedHat in forum Linux - General Topics
    Replies: 1
    Last Post: 04-22-2003, 10:34 PM
  3. modem trouble post kernel recompile
    By cj171 in forum Linux - General Topics
    Replies: 13
    Last Post: 09-22-2002, 02:43 AM
  4. problem with X post kernel recompile
    By cj171 in forum Linux - General Topics
    Replies: 13
    Last Post: 08-29-2002, 03:22 PM
  5. No DSL after 2.4.x kernel recompile
    By ifred in forum Linux - General Topics
    Replies: 4
    Last Post: 01-04-2002, 04:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •