Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Connecting to 2003 server
Results 1 to 7 of 7

Thread: Connecting to 2003 server

  1. #1

    Connecting to 2003 server

    Using Slack 10

    Trying to connect to Windows 2003 server. Heres the output

    root@darkstar:~# mount -t smbfs //192.168.0.1/data /mnt/network/
    cli_negprot: SMB signing is mandatory and we have disabled it.
    1475: protocol negotiation failed
    SMB connection failed

    Have already tried putting this in /etc/samba/smb.conf

    client use spnego = yes
    client signing = mandatory

    I cannot configure the 2003 server, not mine.
    any ideas how to overcome this?
    Its better to regret something you have done than to regret something you havent done :P

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re: Connecting to 2003 server

    Since I haven't upgraded to slack 10 yet, I have to ask... is it samba 3?

    The options you have set only work with samba 3 i believe. If it isn't, upgrade then try again.

  3. #3
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re: Connecting to 2003 server


  4. #4

    Re: Connecting to 2003 server

    Good god!
    cifs plifs miffs biffs

    Im confused, too much beer maybe?
    Anyone can start the wheel turning for me?

    i.e. What the hell do i have to do? where do i start
    Its better to regret something you have done than to regret something you havent done :P

  5. #5
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re: Connecting to 2003 server

    Put the piss-in-a-glass down... step away from the piss... don't drink piss any more

    If you must drink, get a real drink at the very least.

    Now, wait a few days to sober up, then come back and re-read the links I posted.

    CIFS is just like SMB but has support for extras. If you can't get it working by just using samba 3 (you didn't answer the question of what version you're using) then you want to try using the CIFS tools in place of the SMB tools. But if it's not on your system already (and I'm guessing it's not) then you need to install them and they require a kernel recompile.

    Good luck, and drink a real drink... tequila, vodka, rum, sangria... anything but *shudders and pukes...* beer (BEER TASTES LIKE PISS)

  6. #6

    Re: Connecting to 2003 server

    To get this working with samba 2.x you must change the security policy on the windows 2003 server.

    You will most likely get an error like this before following these steps:
    xxxxx: session request to xx failed (Called name not present)
    xxxxx: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
    SMB connection failed

    - smb.conf settings do not apply to smbmount here
    - changing the registry settings manually will only revert to the old setting

    Do it this way:

    1. Start -> Programs -> Administative Tools -> Domain Controller Security Policy
    2. Local Policies -> Security Options
    3. Microsoft network server: Digitally sign communications (always)
    * * Right Click, Properties, Set to "Disabled"
    4. Restart the Group Policy, or Reboot.

  7. #7

    Re: Connecting to 2003 server

    mount -t cifs -o username=blah,password=XXXXXX //server/share /dir/mount

    Use cifs instead of smbfs for the vfstype.

    As indicated above you also need 'client signing = yes' in your smb.conf file.

    Happy mounting.

Similar Threads

  1. problem connecting to win2003 server
    By maenemy in forum Windows - General Topics
    Replies: 1
    Last Post: 09-23-2005, 01:40 PM
  2. Problem in connecting to FTP Server.
    By mohank in forum Linux - General Topics
    Replies: 2
    Last Post: 03-20-2005, 07:20 AM
  3. ISA Server on Windows Server 2003
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 01-01-2005, 09:49 PM
  4. linux apache+php connecting to MS SQL server
    By ph34r in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 11-21-2002, 06:13 PM
  5. Connecting to M$ SQL server
    By cloverm in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 07-16-2002, 03:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •