Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
so close to have my pcmcia NIC working
Results 1 to 2 of 2

Thread: so close to have my pcmcia NIC working

Hybrid View

  1. #1
    aromes
    Guest

    so close to have my pcmcia NIC working

    My pcmcia network card is ready to be set with "ifconfig"
    (at this point, "ifconfig" gives nothing apart the loopback
    interface)..as you can see in the details below.
    Problem is that there's no I/O nor IRQ available for the NIC!

    ->here are the details:

    I did plug a linksys pcmcia ethernet card to my laptop,
    did boot linux Mandrake 7.0 -> at linux boot up, I can
    see "cardmgr" has detected the Linksys Etherfast network card (with no mention of irq, nor I/O).
    ->/sbin/cardctl status and /sbin/cardctl ident
    both detect the card:
    # /sbin/cardctl
    socket 1:
    5V 16-bit pc card
    function 0: [ready],[wp]
    But does not give m eany I/O and IRQ!!!!
    # /sbin/cardctl ident
    Socket 1:
    Product info: "Linksys", "Etherfast 10/100 Integrated PC Card (PCM100), "Ver 1.0"
    manfid: 0x0149, 0xc1ab
    function: 6 (network)
    Is the MANFID the I/O??? What about the IRQ?
    How come the IRQ and I/O are not displayed?
    Actually, even with "LSPCI -V", I do not get any "I/O,IRQ for my network card!
    Same thing for "cat /proc/ioports" and "cat /proc/interrupts".
    All available IRQs and I/O are already taken by other devices.
    More details that tells me that I am so close to have
    the pcmcia working ->
    ->when I run "lsmod" , I get:
    pcmcia_core (used by ds i82365)
    i82365 (used by 2) ..that's the module for my nic right?
    ->card services are running cause
    when I run " ps -ef | grep cardmgr ", I get:
    root 746 1 9 19:05 /sbin/cardmgr
    ->In /etc/sysconfig/pcmcia, I have:
    PCMCIA=yes
    PCIC=i82365
    BUT IN /etc/pcmcia/config, there's no exact entry
    for my nic (such as it was outputted by "/sbin/cardctl ident"). Most of them are linksys e-cards, except for
    the following one:
    ->card "Linksys Ethernet"
    version "Linksys", "Combo PCMCIA Ethernet Card (EC2T)"
    bind "pcnet_cs"
    Actually there's an entry that caught my attention
    cause it has same "MANFID" as the "CARDCTL IDENT" outputs on my system:
    ->card "NE2000 Compatible Ethernet"
    version "Ethernet", "Adapter"
    #manfid 0x0149, 0xc1ab
    bind "pcnet_cs"
    (What's the point of /etc/pcmcia/config? What do I need to do here? should I rely on the ne2000 entry or should I absolutely add or rely on the linksys entries. If I should rely on the ne2000 entry, should I take out the # symbol in front of manfid 0x0149, 0xc1ab ?? ??????)

    I checked all I/O and IRQs with "cat /proc/interrupts" and "cat /proc/ioports"
    and all of them are already taken by other devices.
    The Pcmcia network card is a Linksys Etherfast 10/100 Integrated PC Card v.2".
    Also: At linux bootup, as soon as the card services
    are loaded, I see my NIC leds lighting up..so I guess I am just at one step of having it working.
    I guess I just have to "ifconfig" the NIC card, but
    how am I going to do it without any IRQ and I/O for it.


    Linux Mandrake 7.0
    Kernel 2.4.8
    nic: linksys pcmcia etherfast 10/100 pc card (pcm100 v2)

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re:so close to have my pcmcia NIC working

    My suggestion is to just try ifconfig... if it works, then take the approach of "it's magic" and be done

    If it doesn't work, then let us know and one or more of us will try to help.

    Good luck, and keep us up to date on how you did with it

Similar Threads

  1. Desktop Linux Summit comes to a close ....
    By Schotty in forum General Chat
    Replies: 0
    Last Post: 04-26-2006, 01:01 AM
  2. Massachusetts Should Close Down OpenDocument
    By comtux in forum General Chat
    Replies: 2
    Last Post: 10-01-2005, 11:12 AM
  3. Do not allow user to close program
    By countach44 in forum Windows - General Topics
    Replies: 1
    Last Post: 04-12-2005, 05:49 PM
  4. KDE 3.0 final very close to release?
    By JimH in forum Linux - General Topics
    Replies: 4
    Last Post: 04-04-2002, 07:37 PM
  5. How to close down ports with IPCHAINS
    By Compunuts in forum Linux - Software, Applications & Programming
    Replies: 14
    Last Post: 01-22-2002, 10:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •