Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Onboard sound
Results 1 to 3 of 3

Thread: Onboard sound

  1. #1
    johnqpublic
    Guest

    Onboard sound

    I installed Slack 9.1 on one of my newer boxes. The Motherboard is an Abit IT7-MAX2.Problem is onboard sound is Realtek ALC650 (AC-Link) and I cannot get it working in Slackware. I did an xconfig to try find it in the kernel but did not see anything nor did I in rc.modules.It works fine in SuSE 9.0 and Libranet 2.8.1Does someone know how to get this configured?What driver do I need?
    Thank you folks

  2. #2

    Re:Onboard sound

    You'll have to setup for ALSA since 9.1 uses that by default. Don't ask me how, I haven't done it yet. If you already know how to do OSS, then you can always recompile the kernel with OSS, and use that instead.
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  3. #3

    Re:Onboard sound

    well, to start, you always need the soundcore module. Then, it looks like you need the ac97_codec module as well.

    http://www.realtek.com.tw/downloads/...&Software=True

    That is for the ac97_codec.

    http://www.gentoo.org/doc/en/alsa-guide.xml

    Sorry that that is for gentoo, but it is exactly the same for slackware, except you must compile alsa-driver and alsa-util. I am also not sure that the config files are in the same spots, but they certainly keep the same names

Similar Threads

  1. Onboard Sound
    By johnmann in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 12-03-2003, 03:02 PM
  2. onboard sound problem!!
    By dox in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 09-15-2003, 12:39 AM
  3. Onboard Sound
    By kornp in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 10-03-2002, 01:02 AM
  4. POS VIA onboard sound
    By CP in forum Linux - Hardware, Networking & Security
    Replies: 11
    Last Post: 07-26-2002, 07:31 AM
  5. SoundCard: onboard sound vs PCI card
    By Blaqb0x in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 05-26-2002, 10:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •