Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Problems with font server in RH9
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Problems with font server in RH9

  1. #1
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Problems with font server in RH9

    Hi,

    I recently upgraded from RH7.3 to RH9. I now have a system that is much nicer to look at but a lot less stable- it's nearly as bad as Windoze!

    I think the problem lies in the X font server-- I'm not a techie type so I might have this wrong. What happens is it starts off OK, but after I've been using it for a while I get weird stuff happening:

    1. Screensaver (Xscreensaver) starts to not work correctly... won't start when click "lock screen", or stops with a key stroke instead of requiring password.
    2. Moneydance, which is java-based won't start up. Running from console, get messages that it can't get fonts.
    3. Running ispell as spellchecker in sylpheed, I get similar error messages
    4. Evolution, which I only use as calendar, breaks down after a while also... says the module has stopped working.
    5. If I log out of gnome the monitor clicks between graphics and text mode before coming up with an error that says it can't restart X and do i want to run the configuration program? The only way out of this is to shutdown and restart.
    6. When shutting down the line shutting down xfs always comes back with "failed"

    I'm toying with the idea of doing a complete install of RH9 but that would probably be too much hard work to get all my software back to where it is now.

    Any ideas on what i should do?

    Thanks.

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re:Problems with font server in RH9

    I don't use RPM's so I can't give you more advice than this:

    try uninstalling the xfontserver rpm and then install it again.

  3. #3

    Re:Problems with font server in RH9

    Run xscreensaver with the lock screen when it is being buggy. Then goto console and type dmesg and paste the results of that here.

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  4. #4
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Re:Problems with font server in RH9

    Hi Aragorn,

    I tried to cut and paste the output from dmesg, but it said the message was too long. I've posted it at:

    www.pastornet.net.au/NewLifeN/dmesg.txt

    Keith

  5. #5

    Re:Problems with font server in RH9

    Alright, well that didn't have what I was looking for, so give me a copy of this log, just like the last 20-30 lines.

    /var/log/XFree86.0.log

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  6. #6
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Re:Problems with font server in RH9

    From /var/log/XFree86.0.log:

    (**) Option "dpms"
    (**) VESA(0): DPMS enabled
    (==) RandR enabled
    (II) Setting vga for screen 0.
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension LBX
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (**) Option "Protocol" "Microsoft"
    (**) Mouse0: Protocol: "Microsoft"
    (**) Option "CorePointer"
    (**) Mouse0: Core Pointer
    (**) Option "Device" "/dev/ttyS0"
    (**) Option "BaudRate" "1200"
    (**) Option "StopBits" "1"
    (**) Option "DataBits" "7"
    (**) Option "Parity" "None"
    (**) Option "Vmin" "1"
    (**) Option "Vtime" "0"
    (**) Option "FlowControl" "None"
    (**) Option "Emulate3Buttons" "yes"
    (**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
    (**) Option "ZAxisMapping" "4 5"
    (**) Mouse0: ZAxisMapping: buttons 4 and 5
    (**) Mouse0: Buttons: 5
    (**) Mouse0: BaudRate: 1200
    (II) Keyboard "Keyboard0" handled by legacy driver
    (**) Option "Protocol" "IMPS/2"
    (**) DevInputMice: Protocol: "IMPS/2"
    (**) Option "AlwaysCore"
    (**) DevInputMice: always reports core events
    (**) Option "Device" "/dev/input/mice"
    (**) Option "Emulate3Buttons" "no"
    (**) Option "ZAxisMapping" "4 5"
    (**) DevInputMice: ZAxisMapping: buttons 4 and 5
    (**) DevInputMice: Buttons: 5
    (II) XINPUT: Adding extended input device "DevInputMice" (type: MOUSE)
    (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
    (II) DevInputMice: ps2EnableDataReporting: succeeded
    GetModeLine - scrn: 0 clock: 0
    GetModeLine - hdsp: 1024 hbeg: 0 hend: 0 httl: 0
    vdsp: 768 vbeg: 0 vend: 0 vttl: 0 flags: 0
    GetModeLine - scrn: 0 clock: 0
    GetModeLine - hdsp: 1024 hbeg: 0 hend: 0 httl: 0
    vdsp: 768 vbeg: 0 vend: 0 vttl: 0 flags: 0
    GetModeLine - scrn: 0 clock: 0
    GetModeLine - hdsp: 1024 hbeg: 0 hend: 0 httl: 0
    vdsp: 768 vbeg: 0 vend: 0 vttl: 0 flags: 0
    GetModeLine - scrn: 0 clock: 0
    GetModeLine - hdsp: 1024 hbeg: 0 hend: 0 httl: 0
    vdsp: 768 vbeg: 0 vend: 0 vttl: 0 flags: 0
    GetModeLine - scrn: 0 clock: 0
    GetModeLine - hdsp: 1024 hbeg: 0 hend: 0 httl: 0
    vdsp: 768 vbeg: 0 vend: 0 vttl: 0 flags: 0

  7. #7

    Re:Problems with font server in RH9

    Well all of that looks ok too. Is it not coming on when you click lock screen?

    I would go ahead and do a removal of xfs and do a reinstall.

    rpm -e xfs
    then after it removes do a reinstall
    rpm -ivh xfs

    Aragorn
    If you give a man a fire he'll be warm, if you light the man on fire he'll be warm for life.

  8. #8

    Re:Problems with font server in RH9

    hmm
    did you do an upgrade of redhat, or a fresh install?
    maybe the upgrade might have broken something
    whatdoyougetwhenyoumultiplysixbynine??

  9. #9
    Junior Member
    Join Date
    Jul 2001
    Posts
    91

    Re:Problems with font server in RH9

    Hi Aragorn,

    I removed and re-installed xfs and it's working like a charm. My computer was accidentally left on last night so it's been running continually for amost 24 hours and all is still well.

    thanks for your help!

    Keith

  10. #10
    Senior Member
    Join Date
    Nov 2001
    Posts
    304

    Re:Problems with font server in RH9

    shoulda listened to me in the first place ;D

    Just kidding glad to hear you got it working.

Similar Threads

  1. wireless linux server problems
    By tBStar in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 06-25-2006, 06:10 AM
  2. problems setting up a mail server
    By mountainman in forum Linux - Hardware, Networking & Security
    Replies: 15
    Last Post: 02-02-2006, 09:20 PM
  3. Problems Setting up Mail Server
    By petcol in forum Linux - General Topics
    Replies: 2
    Last Post: 05-30-2005, 12:05 AM
  4. qmailadmin problems - no links to admin the server!
    By jme in forum Linux - General Topics
    Replies: 0
    Last Post: 08-28-2004, 11:13 AM
  5. gaim font problems
    By Tyr_7BE in forum Linux - General Topics
    Replies: 1
    Last Post: 04-13-2003, 03:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •