Yep, maybe the damn 2.4.21 kernel will support my High-Point Tech. 374 controller. I hope, I hope, I hope.Been without Linux since early June and this is getting on my nerves!