Results 1 to 3 of 3

Thread: Apache Authentication Problem

  1. #1

    Apache Authentication Problem

    Could you please help me with this one. I am running Apache-2.x inside my LAN and wanted to protect some of its web page directories with passwords.

    Here's my http.conf entries

    <Directory "/var/www/html/private/">
    Options None
    AllowOverride AuthConfig
    AuthName "Pls enter Password"
    AuthType Basic
    AuthDBMUserFile /etc/httpd/dbmpasswd
    require valid-user user1 user2

    My /etc/httpd/conf/httpd.conf
    LoadModule auth_module modules/
    LoadModule auth_dbm_module modules/

    I already Create the password file:
    /usr/sbin/dbmmanage /etc/httpd/dbmpasswd user1
    /usr/sbin/dbmmanage /etc/httpd/dbmpasswd user2

    Had Restarted Apache:
    /etc/init.d/httpd restart

    but whenever I invoked this command:
    #dbmmanage /home/httpd/htdocs/html/private/users view

    Can't tie /var/www/html/private/users: No such file or directory at /usr/sbin/dbmmanage line 196.

    Therefore can't also make users access the private folder.

    Help me pls. I'm already stuck for a couple of weeks now.


  2. #2
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001

    Re:Apache Authentication Problem

  3. #3

    Re:Apache Authentication Problem

    [quote author=Compunuts link=board=1;threadid=8096;start=0#msg73640 date=1068451608]
    Check this out here.

    HTH ..

    I visited and made the procedures but can't seem to find the answer to my questions.

    Pls shed some light as my I am a so confused already, since I am already stuck with this problem for a couple of weeks now.

    I am currently working with my apache-2.x server which also my squirrel mail server. I currently use .htaccess for my web client's authentication.

    The directives discussed in this article will need to go either in your main server configuration file (typically in a <Directory> section), or in per-directory configuration files (.htaccess files).

    ----In my case I wan't to use the DIRECTORY SERVER CONFIG. But have an existing .htaccess for my WEBMAIL DIRECTORY. Does this one have something to do with my problem?

    Because, my apache logs provides the following:

    Permission denied: /home/httpd/htdocs/html/private/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    Yet, I used the DIRECTORY SERVER CONFIG FILE FOR MY USER AUTHENTICATION. How come it is still seeking for .htaccess file when I haven't define it in my http.conf directives?

    <Directory "/var/www/html/private/">
    Options None
    AllowOverride AuthConfig
    AuthName "Pls enter Password"
    AuthType Basic
    AuthDBMUserFile /etc/httpd/dbmpasswd
    require valid-user user1 user2

    Also, dbmmage view option provides the following:

    # /usr/sbin/dbmmanage /etc/httpd/dbmpasswd view

    How come I can't get that authentication?

    Pls help me : (

Similar Threads

  1. squid user authentication problem!!!!!!!!!!!!pls help
    By swapnil in forum Linux Distros
    Replies: 2
    Last Post: 06-02-2010, 04:31 PM
  2. problem on vsftpd authentication againts ldap
    By haari_seshu in forum Redhat / Fedora
    Replies: 0
    Last Post: 07-28-2008, 05:12 AM
  3. Squid + NTLM -- Yahoo messenger authentication problem
    By Suhas! in forum Redhat / Fedora
    Replies: 2
    Last Post: 07-23-2007, 06:02 AM
  4. Apache Basic Authentication not working in Gentoo
    By libregeek in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 03-15-2006, 03:26 AM
  5. Apache and PHP problem
    By imported_root in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 04-21-2005, 02:13 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts