Okie dokie... I went into the control center and set my default browser to be opera. Any html, htm, etc. files open with opera when I click them. However, if I receive an email through Evolution that has a URL on it, it will open with Mozilla. I can't find any option to change this. Has anyone had this problem and been able to solve it? Thanks.