Results 1 to 6 of 6

Thread: Mandrake 9.1 Install Headackes

  1. #1

    Mandrake 9.1 Install Headackes

    Help, ... anyone please!!!
    I've been trying to get a working install of 9.1 on my machine all weekend with little success.
    I have a 60gig drive with XP pro on it and another removable 40gig drive with 30 gig as win 98 and I wanted to install the remaining 10 gig with Linux 9.1.
    It went through the whole install ok and rebooted to the LILO ok the first time and booted Linux properly. But I can't use the LILO because when I remove the 40 gig drive and only try and use the 60gig, it won't load XP, so I have to remove the LILO and boot from a floppy. I've done this succesfully before with other versions of Mandrake but I can't get it to work with 9.1 It starts to boot but then comes up with this error:
    { mounting root filesystem
    VFS: Can't find ext3 filesystem on dev ide0(3,65).
    mount: error 22 mounting ext3 flags Mounted devfs
    on /dev
    Freeing unused kernel memory: 136k freed
    Kernel panic: No init found. Try passing init= option to
    So I've tried to use:
    " Boot: Linux init=/dev/hdb5 "
    hdb5 is were my linux root is on the second drive.
    But this doesn't fix the problem. So can anyone helpl me with this problem? I'm going crazy here.

    At the boot: prompt I've been using "It starts to boot and then comes up with this error

  2. #2

    Re:Mandrake 9.1 Install Headackes

    Okay, from what you're telling me, it looks like you've removed the drive with Linux on it, and are now trying to boot it. That doesn't make any sense.

    If you keep all the drives in the PC, then LiLo should boot the Linux drive just fine. BTW did you install LiLo into the 40 GB drive, or the 60 GB drive? Which one is hda, hdb, etc..?
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  3. #3

    Re:Mandrake 9.1 Install Headackes

    ;D Sheeesh.... Finally got it!!!
    Thanks for the responses guys and sorry for the poor explanation of the problem, (was in a rush and getín pestered by about 3 people at the time, lol)

    For those who are still curious, Iíll try to make it a little clearer just incase someone is having the same problem that I had.

    - I have windows XP pro installed on my internal 60 gig drive.
    - I have windows í98 installed on 30 gigs of my removable 40 gig drive
    (partition 1).
    - I have Mandrake 9.1 installed on the remaining 10 gigs of the 40 gig
    removable drive {partitions: 5 (root), 6 (swap), 7 (home)}.

    When my computer boots, the bios scans the drives and comes up with a list of my bootable devices: 60 gig, 40gig, CD rom, CD writer, floppy.

    The removable drive bay gets different drives in it from time to time, sometimes no drive at all. Therefore the LILO canít reside on the 60gig because it crashes when there is no drive in the removable drive bay or the drive bay contains a non-linux disk.

    What I finally did to get around this was:

    1) Installed Linux on the remainder of the removable drive as normal,
    but I told the installation to put the LILO boot loader on hdb
    (Ď98/Linux drive) instead of hda (XP only). However, it installed it on
    both drives anyways, lol.
    2) Then, did an fdisk /mbr on the 60 gig drive, Ö now my XP boots as
    normal. My Linux on hdb boots fine using the LILO however, the í98
    on hdb didnít boot properly. >
    3) To fix this problem, I disconnected the 60gig drive and made the 40
    gig the master. Then did a fdisk /mbr to the 40 gig (Ď98/Linux) drive.
    Then reconnected things back up again.
    4) Then booted Linux with a floppy and that worked great. Now my XP
    boots as normal whether there is a drive installed in the removable
    bay or not, my í98 on the second drive boots properly, and my Linux
    boots from floppy when the drive is installed. ;D

  4. #4

    Re:Mandrake 9.1 Install Headackes

    install headaches.... wait till you start trying to learn linux from mandrake =P
    AMD Athlon XP 2500+<br />DFI NFII Ultra Infinity(gigabyte sucks)<br />OCZ 2 x 512 PC3200<br />ATI Radeon AIW 9600 PRO<br />16x DVD-Rom (not in use)<br />LG 8x DVD-Burner<br />LG 40x12x40 CD-RW<br />WD 120GB<br />420W PSU<br />Tweaked out case<br />:)

  5. #5

    Re:Mandrake 9.1 Install Headackes

    I have had probs like that! That's why I use a third party boot manager. Always have as I hate to install LiLo to the MBR and hate using boot floppies. 8)

  6. #6

    Re:Mandrake 9.1 Install Headackes

    why not have hda being xp take up 50, linux take up 10 on hda, and set partitions for the other drive, so hdb can be like 20 20 and the second 20 can be like a backup type thing where you keep important files like drivers and such, quite usefull this way and then linux wont disapear.
    AMD Athlon XP 2500+<br />DFI NFII Ultra Infinity(gigabyte sucks)<br />OCZ 2 x 512 PC3200<br />ATI Radeon AIW 9600 PRO<br />16x DVD-Rom (not in use)<br />LG 8x DVD-Burner<br />LG 40x12x40 CD-RW<br />WD 120GB<br />420W PSU<br />Tweaked out case<br />:)

Similar Threads

  1. HELP:newbie try install mandrake 9.2
    By Janne74 in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 03-28-2004, 12:12 PM
  2. Mandrake 9.1 won't install
    By in forum Linux - General Topics
    Replies: 52
    Last Post: 10-05-2003, 08:33 PM
  3. Mandrake 8.0 2nd install cd .....please....
    By boblucci in forum General Chat
    Replies: 4
    Last Post: 08-03-2002, 04:19 AM
    By microwiz2 in forum Linux - General Topics
    Replies: 1
    Last Post: 04-18-2002, 08:33 PM
  5. RH 7.1 and Mandrake 8.1 install problem
    By conroe in forum Redhat / Fedora
    Replies: 6
    Last Post: 12-18-2001, 07:04 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts